aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-12 12:59:09 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-12 12:59:09 +0000
commitdda53c2ce2cbc08d199cf85fbfaec43796332ce0 (patch)
tree5efc80af80cdcd2b1cae30c001ac4fbb593e7f31 /package/linux-atm
parent1a84e828c133ce570197c18f639186a179153b4a (diff)
downloadupstream-dda53c2ce2cbc08d199cf85fbfaec43796332ce0.tar.gz
upstream-dda53c2ce2cbc08d199cf85fbfaec43796332ce0.tar.bz2
upstream-dda53c2ce2cbc08d199cf85fbfaec43796332ce0.zip
[package] fix linux-atm build failure on brcm63xx (and probably other targets) (#7145)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20826 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index c8a18c3d31..fd92cc1fff 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -47,13 +47,13 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/stamp-h.in
endef
-TARGET_CFLAGS += -I$(LINUX_DIR)/include
+TARGET_CFLAGS += -I$(LINUX_DIR)/include -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include
define Build/Compile
# src/qgen is built with HOSTCC, which does not really like our LDFLAGS
$(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \
LDFLAGS="" \
- all
+ all
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install