aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2011-01-29 02:14:22 +0000
committerFlorian Fainelli <florian@openwrt.org>2011-01-29 02:14:22 +0000
commit338276cab2da6df653d5506bc3f89732e35f727e (patch)
treec23990225ffe1c15ec4aa8419cb523f96ed90ca5 /package/linux-atm/Makefile
parent57fd328159ed0039352f8b2e5d90ce8eea11b90d (diff)
downloadupstream-338276cab2da6df653d5506bc3f89732e35f727e.tar.gz
upstream-338276cab2da6df653d5506bc3f89732e35f727e.tar.bz2
upstream-338276cab2da6df653d5506bc3f89732e35f727e.zip
[package] br2684ctl from linux-atm
Signed-off-by: Philip Prindeville <philipp_subx@redfish-solutions.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25225 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/linux-atm/Makefile')
-rw-r--r--package/linux-atm/Makefile24
1 files changed, 22 insertions, 2 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 39db05ef9f..8a759df566 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=linux-atm
PKG_VERSION:=2.5.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
@@ -43,6 +43,18 @@ define Package/atm-tools/description
This package contains the Linux ATM tools.
endef
+define Package/br2684ctl
+ SECTION:=net
+ CATEGORY:=Network
+ DEPENDS:=linux-atm
+ TITLE:=ATM Ethernet bridging configuration utility
+ URL:=http://linux-atm.sourceforge.net/
+endef
+
+define Package/br2684ctl/description
+ Support for AAL5 encapsulation (RFC-1483/RFC-2684) over ATM.
+endef
+
define Build/Configure
$(call Build/Configure/Default)
# prevent autoheader invocation
@@ -109,5 +121,13 @@ define Package/atm-tools/install
# $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/ttcp_atm $(1)/usr/bin/
endef
+define Package/br2684ctl/install
+ $(INSTALL_DIR) $(1)/etc/init.d/
+ $(INSTALL_BIN) ./files/br2684ctl $(1)/etc/init.d/
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/br2684ctl $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,linux-atm))
$(eval $(call BuildPackage,atm-tools))
+$(eval $(call BuildPackage,br2684ctl))