aboutsummaryrefslogtreecommitdiffstats
path: root/package/libtool
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2009-06-04 00:20:01 +0000
committerLars-Peter Clausen <lars@metafoo.de>2009-06-04 00:20:01 +0000
commita5b1993a12f95ce55e2b4be343e3073803642c84 (patch)
treeffbbaad0d3816d7d0c474f7e8eb7092dfbf4e6af /package/libtool
parentdad297d9c2ddc88f7de1780df13bbf1770683adb (diff)
downloadupstream-a5b1993a12f95ce55e2b4be343e3073803642c84.tar.gz
upstream-a5b1993a12f95ce55e2b4be343e3073803642c84.tar.bz2
upstream-a5b1993a12f95ce55e2b4be343e3073803642c84.zip
More libtool madness: Every package which was using c++ and libtool fixup
was linked against libstd++ even though if it should have been linked against uclibc++. This is fixed by providing a special version of libtool fixup for packages which should use uclibc++. Not pretty but functional. Packages linking against uclibc++ should use PKG_FIXUP:=libtool-ucxx instead of PKG_FIXUP:=libtool Somebody should probably check all packages using c++ with a dependency on stdlibc++ if uclibc++ can be used instead now. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libtool/Makefile b/package/libtool/Makefile
index f179cd7c2a..8d50a7adac 100644
--- a/package/libtool/Makefile
+++ b/package/libtool/Makefile
@@ -45,6 +45,8 @@ define Build/InstallDev
mv $(2)/lib/* $(1)/usr/lib/
mv $(2)/include/* $(1)/usr/include/
$(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
+ $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
+ $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
endef
define Package/libltdl/install