aboutsummaryrefslogtreecommitdiffstats
path: root/package/libtool
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-12-18 18:12:34 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-12-18 18:12:34 +0000
commit7039a63af59c67ecf7ea87f50a72aedf4a7fc335 (patch)
treed05d1d8a91f4ba4389374ebcc9c99f26285bde6b /package/libtool
parent39140aae07f84e788660fa1bbb698873af38a943 (diff)
downloadupstream-7039a63af59c67ecf7ea87f50a72aedf4a7fc335.tar.gz
upstream-7039a63af59c67ecf7ea87f50a72aedf4a7fc335.tar.bz2
upstream-7039a63af59c67ecf7ea87f50a72aedf4a7fc335.zip
[package] libtool: remove host build and leave only libltdl in place
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/package/libtool/Makefile b/package/libtool/Makefile
index 1349070d5d..b33eda14a2 100644
--- a/package/libtool/Makefile
+++ b/package/libtool/Makefile
@@ -15,12 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/libtool
PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
-PKG_BUILD_DEPENDS:=libtool/host
-
PKG_BUILD_PARALLEL:=0
-HOST_BUILD_PARALLEL:=0
-include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
CONFIGURE_PREFIX=$(STAGING_DIR)/host
@@ -43,9 +39,6 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
mv $(2)/lib/* $(1)/usr/lib/
mv $(2)/include/* $(1)/usr/include/
- $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
- $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
- $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
endef
define Package/libltdl/install
@@ -53,5 +46,4 @@ define Package/libltdl/install
$(CP) $(PKG_BUILD_DIR)/libltdl/.libs/libltdl.so.* $(1)/usr/lib/
endef
-$(eval $(call HostBuild))
$(eval $(call BuildPackage,libltdl))