aboutsummaryrefslogtreecommitdiffstats
path: root/package/libtool
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-27 02:10:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-27 02:10:23 +0000
commit170b173b6ff08df8c26bdf2b63624b1cae790547 (patch)
treefff27b4925ea0996d238a0479dcc17f87358bcf6 /package/libtool
parentd4462fd4e00d79e43b4fa499060143f6aeedf768 (diff)
downloadupstream-170b173b6ff08df8c26bdf2b63624b1cae790547.tar.gz
upstream-170b173b6ff08df8c26bdf2b63624b1cae790547.tar.bz2
upstream-170b173b6ff08df8c26bdf2b63624b1cae790547.zip
move libtool out of tools/, seems like we need a per-target libtool
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9937 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libtool')
-rw-r--r--package/libtool/Makefile46
-rw-r--r--package/libtool/patches/001-force_dlopen_deplibs.patch14
2 files changed, 60 insertions, 0 deletions
diff --git a/package/libtool/Makefile b/package/libtool/Makefile
new file mode 100644
index 0000000000..1aad641986
--- /dev/null
+++ b/package/libtool/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtool
+PKG_VERSION:=1.5.22
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/libtool
+PKG_MD5SUM:=8e0ac9797b62ba4dcc8a2fb7936412b0
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_PREFIX=$(STAGING_DIR)/host
+
+define Package/libltdl
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=A generic dynamic object loading library
+ URL:=http://www.gnu.org/software/libtool/
+endef
+
+define Build/InstallDev
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ prefix="$(2)" \
+ exec_prefix="$(2)" \
+ install
+ $(INSTALL_DIR) $(1)/lib
+ mv $(2)/lib/* $(1)/lib/
+endef
+
+define Package/libltdl/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libltdl/.libs/libltdl.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libltdl))
diff --git a/package/libtool/patches/001-force_dlopen_deplibs.patch b/package/libtool/patches/001-force_dlopen_deplibs.patch
new file mode 100644
index 0000000000..dfcf56b320
--- /dev/null
+++ b/package/libtool/patches/001-force_dlopen_deplibs.patch
@@ -0,0 +1,14 @@
+diff -urN libtool-1.5.14/libltdl/acinclude.m4 libtool-1.5.14.new/libltdl/acinclude.m4
+--- libtool-1.5.14/libltdl/acinclude.m4 2005-02-12 13:20:02.000000000 +0100
++++ libtool-1.5.14.new/libltdl/acinclude.m4 2006-04-17 23:00:24.000000000 +0200
+@@ -6228,10 +6228,8 @@
+ ;;
+ esac
+ ])
+-if test "$libltdl_cv_sys_dlopen_deplibs" != yes; then
+ AC_DEFINE([LTDL_DLOPEN_DEPLIBS], [1],
+ [Define if the OS needs help to load dependent libraries for dlopen().])
+-fi
+ ])# AC_LTDL_SYS_DLOPEN_DEPLIBS
+
+