aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorJitao Lu <dianlujitao@gmail.com>2023-06-14 17:25:03 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-06-17 12:55:29 +0200
commite9d2ff8045f803ec5c90b965946fa1162d5a5699 (patch)
tree6ab756881b8f00b8a7e91c7c443d90d1a891e53a /package/libs
parenta46e5ce4adaa02263bbe14568e0e714b297e6b91 (diff)
downloadupstream-e9d2ff8045f803ec5c90b965946fa1162d5a5699.tar.gz
upstream-e9d2ff8045f803ec5c90b965946fa1162d5a5699.tar.bz2
upstream-e9d2ff8045f803ec5c90b965946fa1162d5a5699.zip
openssl: passing cflags to configure
openssl sets additional cflags in its configuration script. We need to make it aware of our custom cflags to avoid adding conflicting cflags. Fixes: #12866 Signed-off-by: Jitao Lu <dianlujitao@gmail.com> (cherry picked from commit 51f57e7c2dd2799e34036ec74b3436bf490fade0)
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/openssl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index a34a784973..0d09114f06 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=3.0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_FLAGS:=no-mips16 gc-sections
PKG_BUILD_PARALLEL:=1
@@ -366,6 +366,7 @@ define Build/Configure
--libdir=lib \
--openssldir=/etc/ssl \
--cross-compile-prefix="$(TARGET_CROSS)" \
+ $(TARGET_CFLAGS) \
$(TARGET_CPPFLAGS) \
$(TARGET_LDFLAGS) \
$(OPENSSL_OPTIONS) && \