aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 01:35:45 +0200
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>2022-06-09 01:35:45 +0200
commiteac1b8ab699eb3383e6d5d39b53fa9f32ee6eb60 (patch)
treec95d7092d5bd0e9748f2c84b50baf157205fca29 /package/libs
parente0cc5b9b3ae65113f0e0dd9249dae4776b65c503 (diff)
downloadupstream-eac1b8ab699eb3383e6d5d39b53fa9f32ee6eb60.tar.gz
upstream-eac1b8ab699eb3383e6d5d39b53fa9f32ee6eb60.tar.bz2
upstream-eac1b8ab699eb3383e6d5d39b53fa9f32ee6eb60.zip
Revert "wolfssl: set nonshared flag global"
This reverts commit e0cc5b9b3ae65113f0e0dd9249dae4776b65c503. A better and correct solution was found. Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/wolfssl/Makefile10
1 files changed, 1 insertions, 9 deletions
diff --git a/package/libs/wolfssl/Makefile b/package/libs/wolfssl/Makefile
index 7176995ec2..3edd526364 100644
--- a/package/libs/wolfssl/Makefile
+++ b/package/libs/wolfssl/Makefile
@@ -48,15 +48,6 @@ PKG_CONFIG_DEPENDS+=\
CONFIG_WOLFSSL_HAS_DEVCRYPTO_CBC \
CONFIG_WOLFSSL_HAS_DEVCRYPTO_FULL
-#
-# libwolfssl-benchmark should NOT be compiled as nonshared but
-# currently there is a bug where on buildbot stage2 the package
-# is recompiled to build libwolfssl-benchmark and the dependency
-# change to the new libwolfssl version. While this gets
-# investigated, set the nonshared flag global
-#
-PKGFLAGS:=nonshared
-
include $(INCLUDE_DIR)/package.mk
define Package/libwolfssl/Default
@@ -69,6 +60,7 @@ endef
define Package/libwolfssl
$(call Package/libwolfssl/Default)
TITLE:=wolfSSL library
+ PKGFLAGS:=nonshared
MENU:=1
PROVIDES:=libcyassl
DEPENDS:=+WOLFSSL_HAS_DEVCRYPTO:kmod-cryptodev +WOLFSSL_HAS_AFALG:kmod-crypto-user