aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorLinhui Liu <liulinhui36@gmail.com>2023-05-13 17:40:32 +0800
committerNick Hainke <vincent@systemli.org>2023-05-18 10:14:13 +0200
commit91c75c31244b8d6c3b8cb48fca305d558e26c636 (patch)
treed0386a2bfc9c61c7b76cfad8fc1370edb949dd69 /package/libs
parenta1c3f08eae09838f9d14c700044fcad43028c690 (diff)
downloadupstream-91c75c31244b8d6c3b8cb48fca305d558e26c636.tar.gz
upstream-91c75c31244b8d6c3b8cb48fca305d558e26c636.tar.bz2
upstream-91c75c31244b8d6c3b8cb48fca305d558e26c636.zip
libselinux: update to 3.5
Switch from libpcre to libpcre2. While working on it remove the double defined HOST_BUILD_DEPENDS section. Release Notes: https://github.com/SELinuxProject/selinux/releases/download/3.4/RELEASE-3.4.txt https://github.com/SELinuxProject/selinux/releases/download/3.5/RELEASE-3.5.txt Signed-off-by: Linhui Liu <liulinhui36@gmail.com> [depend on libpcre2] Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libselinux/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/package/libs/libselinux/Makefile b/package/libs/libselinux/Makefile
index a794270450..db2221d7e3 100644
--- a/package/libs/libselinux/Makefile
+++ b/package/libs/libselinux/Makefile
@@ -6,20 +6,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libselinux
-PKG_VERSION:=3.3
-PKG_RELEASE:=2
+PKG_VERSION:=3.5
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/$(PKG_VERSION)
-PKG_HASH:=acfdee27633d2496508c28727c3d41d3748076f66d42fccde2e6b9f3463a7057
-HOST_BUILD_DEPENDS:=libsepol/host pcre/host
+PKG_HASH:=9a3a3705ac13a2ccca2de6d652b6356fead10f36fb33115c185c5ccdf29eec19
PKG_LICENSE:=libselinux-1.0
PKG_LICENSE_FILES:=LICENSE
PKG_MAINTAINER:=Thomas Petazzoni <thomas.petazzoni@bootlin.com>
PKG_CPE_ID:=cpe:/a:selinuxproject:libselinux
-HOST_BUILD_DEPENDS:=libsepol/host musl-fts/host pcre/host
+HOST_BUILD_DEPENDS:=libsepol/host musl-fts/host pcre2/host
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -72,7 +71,7 @@ define Package/libselinux
$(call Package/libselinux/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libsepol +libpcre +USE_MUSL:musl-fts
+ DEPENDS:=+libsepol +libpcre2 +USE_MUSL:musl-fts
endef
define Package/libselinux/description