aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2022-03-19 16:51:43 -0700
committerChristian Lamparter <chunkeey@gmail.com>2022-03-27 14:38:13 +0200
commit8a5d095969e14e8a06975e61739facd0edd835cc (patch)
treed2fb8b30d453c864790a16bef4850d1ca5baa3fa /package/libs
parentf8571749a77ea23b418c84692220083858c1df79 (diff)
downloadupstream-8a5d095969e14e8a06975e61739facd0edd835cc.tar.gz
upstream-8a5d095969e14e8a06975e61739facd0edd835cc.tar.bz2
upstream-8a5d095969e14e8a06975e61739facd0edd835cc.zip
elfutils: fix host compilation with Alpine Linux
intl is not included in libc, disable it as is done with the target package. argp is also not included. Add build depends for argp-standalone. fts is also not included. Add build depends for musl-fts. Disable shared libraries to avoid having to manually add rpath. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/elfutils/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 9aa78d8352..07b3ea66c6 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -24,6 +24,8 @@ PKG_INSTALL:=1
PKG_USE_MIPS16:=1
PKG_BUILD_DEPENDS:=!USE_GLIBC:argp-standalone
+HOST_BUILD_DEPENDS:=argp-standalone/host musl-fts/host
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
include $(INCLUDE_DIR)/host-build.mk
@@ -62,6 +64,8 @@ CONFIGURE_ARGS += --disable-nls
endif
HOST_CONFIGURE_ARGS += \
+ --disable-shared \
+ --disable-nls \
--disable-debuginfod \
--disable-libdebuginfod \
--without-lzma \