aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-08-15 19:00:02 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2021-12-21 21:36:55 +0200
commit38c3ead82078c5970f01034d10f42c4542dce68e (patch)
tree82aa5d13b6553a7a87f40ea790f77e739cfa36d0 /package/libs
parentac8673ff85fe334913382b5cabb6cf3079b91e24 (diff)
downloadupstream-38c3ead82078c5970f01034d10f42c4542dce68e.tar.gz
upstream-38c3ead82078c5970f01034d10f42c4542dce68e.tar.bz2
upstream-38c3ead82078c5970f01034d10f42c4542dce68e.zip
nettle: disable assembler on ppc64
As of version 3.7, Nettle added PowerPC64 assembly for several algorithms. Unfortunately, they cause build to fail due to ABI mismatch: gcm-hash.o: ABI version 1 is not compatible with ABI version 2 output Disable assembler when ppc64 and musl are used for now. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Acked-by: Rui Salvaterra <rsalvaterra@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/nettle/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/nettle/Makefile b/package/libs/nettle/Makefile
index 3b4bd9d053..87853baa82 100644
--- a/package/libs/nettle/Makefile
+++ b/package/libs/nettle/Makefile
@@ -44,7 +44,8 @@ CONFIGURE_ARGS += \
--enable-fat \
--disable-openssl \
--disable-documentation \
- --enable-static
+ --enable-static \
+ $(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--disable-assembler))
ifeq ($(CONFIG_LIBNETTLE_MINI),y)
CONFIGURE_ARGS += --enable-mini-gmp