aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-03-25 15:03:53 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-04-05 00:20:24 +0200
commit3a3fdd62393900fd8c3b61d32f68c028c1c2c79b (patch)
tree99cda0616d55be9740c26805703f607ecf70fd62 /package/libs
parent9ae93c14fb4a9ac89d911813509d8470fffa6903 (diff)
downloadupstream-3a3fdd62393900fd8c3b61d32f68c028c1c2c79b.tar.gz
upstream-3a3fdd62393900fd8c3b61d32f68c028c1c2c79b.tar.bz2
upstream-3a3fdd62393900fd8c3b61d32f68c028c1c2c79b.zip
gettext-full: add gmsgfmt symlink in host install
Some configure scripts look for msgfmt and gmsgfmt. As we don't install the latter, configure might pick up one from staging_dir/hostpkg, and the other from the host: checking for msgfmt... /home/stijn/Development/OpenWrt/openwrt/staging_dir/hostpkg/bin/msgfmt checking for gmsgfmt... /usr/bin/gmsgfmt This could potentially lead to hard to debug undefined behaviour. Install a symlink in the host install phase to avoid this. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> (cherry picked from commit 636cb00ecc8d693c36e48952f6d154f91e0e569e)
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/gettext-full/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/libs/gettext-full/Makefile b/package/libs/gettext-full/Makefile
index 6a97fd5b91..f5f5e00542 100644
--- a/package/libs/gettext-full/Makefile
+++ b/package/libs/gettext-full/Makefile
@@ -88,6 +88,11 @@ define Build/InstallDev
$(SED) '/read dummy/d' $(STAGING_DIR_HOSTPKG)/bin/gettextize
endef
+define Host/Install
+ $(call Host/Install/Default)
+ $(LN) msgfmt $(STAGING_DIR_HOSTPKG)/bin/gmsgfmt
+endef
+
define Package/libintl-full/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.so.* $(1)/usr/lib/