aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorPaul Spooren <mail@aparcar.org>2021-03-28 22:21:49 -1000
committerPaul Spooren <mail@aparcar.org>2021-10-21 11:03:51 -1000
commitdf9ca413229e4059fd6f7853dd554415c37f995b (patch)
tree05eedb1333305d916cfe3f36a1496c1016b050cb /package/libs
parentf509ff77d40766907b4d15dea5c725b6a9a8af18 (diff)
downloadupstream-df9ca413229e4059fd6f7853dd554415c37f995b.tar.gz
upstream-df9ca413229e4059fd6f7853dd554415c37f995b.tar.bz2
upstream-df9ca413229e4059fd6f7853dd554415c37f995b.zip
ncurses: split long line of supported terminfo
The terminfo files were all in one row which is terrible to read. Split them over multiple lines to improve readability. Signed-off-by: Paul Spooren <mail@aparcar.org> (cherry picked from commit 75ea474b9002c758e9a23023f7636258a467704c)
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/ncurses/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index cc1e960a0c..b42f23fa85 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -120,7 +120,18 @@ ifneq ($(HOST_OS),FreeBSD)
mv $$$$dir $$$$(echo -ne "\x$$$$dir"); \
done \
)
- for file in a/ansi d/dumb l/linux r/rxvt r/rxvt-unicode s/screen v/vt100 v/vt102 x/xterm x/xterm-color x/xterm-256color; do \
+ for file in \
+ a/ansi \
+ d/dumb \
+ l/linux \
+ r/rxvt \
+ r/rxvt-unicode \
+ s/screen \
+ v/vt100 \
+ v/vt102 \
+ x/xterm \
+ x/xterm-color \
+ x/xterm-256color; do \
$(INSTALL_DIR) $(1)/usr/share/terminfo/`dirname $$$$file`; \
$(CP) $(PKG_INSTALL_DIR)/usr/share/terminfo/$$$$file \
$(1)/usr/share/terminfo/$$$$file; \