aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2020-04-25 13:59:19 +0200
committerPetr Štetiar <ynezz@true.cz>2020-04-25 13:59:19 +0200
commit6c020577aedd55fea92c90be5226e0331be9d676 (patch)
tree1dffd03dc971f052959dda479a9615bc0f43ff90 /package/libs
parentefe837de842bf4c9df1deae22e4bdaab3f92d960 (diff)
downloadupstream-6c020577aedd55fea92c90be5226e0331be9d676.tar.gz
upstream-6c020577aedd55fea92c90be5226e0331be9d676.tar.bz2
upstream-6c020577aedd55fea92c90be5226e0331be9d676.zip
libpcap: fix build breakage with very high number of simultaneous jobs
Building libpcap with high number (64) of simultaneous jobs fails: In file included from ./fmtutils.c:42:0: ./ftmacros.h:106:0: warning: "_BSD_SOURCE" redefined #define _BSD_SOURCE <command-line>:0:0: note: this is the location of the previous definition ./gencode.c:67:10: fatal error: grammar.h: No such file or directory #include "grammar.h" ^~~~~~~~~~~ compilation terminated. Makefile:99: recipe for target 'gencode_pic.o' failed So fix this by less intrusive way by disabling the parallel builds for this package. Ref: FS#3010 Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libpcap/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index a2c7352f65..e6d9ee75b3 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -20,7 +20,7 @@ PKG_FIXUP:=patch-libtool
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
+PKG_BUILD_PARALLEL:=0
PKG_LICENSE:=BSD-3-Clause
include $(INCLUDE_DIR)/package.mk