aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2018-04-14 14:33:46 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-04-14 14:44:43 +0200
commit09d95e44fc3d1a9f900b7305b10dc241a12d6f37 (patch)
treea8523a95003d961b9afe1061082193a99b31fd20 /package/libs
parent4673a0bffc890b5137d6c20664efad5d01791782 (diff)
downloadupstream-09d95e44fc3d1a9f900b7305b10dc241a12d6f37.tar.gz
upstream-09d95e44fc3d1a9f900b7305b10dc241a12d6f37.tar.bz2
upstream-09d95e44fc3d1a9f900b7305b10dc241a12d6f37.zip
mbedtls: change libmbedcrypto.so soversion back to 0
mbedtls changed in version 2.7.0 and 2.7.2 the soversion of the libmbedcrypto.so library, use the old version again to be able to use the new library with binaries compiled against the old mbedtls library. Some binaries got rebuild to for the 2.7.0 release and are now using libmbedcrypto.so.1, the older ones are still using libmbedcrypto.so.0. Go back to libmbedcrypto.so.0 and make the system rebuild the binaries which were rebuild for 2.7.0 again. This should make the libmbedcrypto.so library be compatible with the old version shipped with 17.01. Fixes: 3ca1438ae0 ("mbedtls: update to version 2.7.2") Fixes: f609913b5c ("mbedtls: update to version 2.7.0") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/mbedtls/Makefile2
-rw-r--r--package/libs/mbedtls/patches/300-soversion-compatibility.patch26
-rw-r--r--package/libs/ustream-ssl/Makefile2
3 files changed, 28 insertions, 2 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 619bbcfef1..caa2405ce9 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mbedtls
PKG_VERSION:=2.7.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
diff --git a/package/libs/mbedtls/patches/300-soversion-compatibility.patch b/package/libs/mbedtls/patches/300-soversion-compatibility.patch
new file mode 100644
index 0000000000..4d33be2686
--- /dev/null
+++ b/package/libs/mbedtls/patches/300-soversion-compatibility.patch
@@ -0,0 +1,26 @@
+mbedtls changed in version 2.7.0 and 2.7.2 the soversion of the
+libmbedcrypto.so library, use the old version again to be able to use
+the new library with binaries compiled against the old library.
+
+--- a/library/CMakeLists.txt
++++ b/library/CMakeLists.txt
+@@ -141,7 +141,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
+
+ if(USE_SHARED_MBEDTLS_LIBRARY)
+ add_library(mbedcrypto SHARED ${src_crypto})
+- set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.2 SOVERSION 2)
++ set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.2 SOVERSION 0)
+ target_link_libraries(mbedcrypto ${libs})
+
+ add_library(mbedx509 SHARED ${src_x509})
+--- a/library/Makefile
++++ b/library/Makefile
+@@ -33,7 +33,7 @@ endif
+
+ SOEXT_TLS=so.10
+ SOEXT_X509=so.0
+-SOEXT_CRYPTO=so.2
++SOEXT_CRYPTO=so.0
+
+ DLEXT=so
+ # OSX shared library extension:
diff --git a/package/libs/ustream-ssl/Makefile b/package/libs/ustream-ssl/Makefile
index b9b9e19dfb..95dd0e8e55 100644
--- a/package/libs/ustream-ssl/Makefile
+++ b/package/libs/ustream-ssl/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ustream-ssl
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(LEDE_GIT)/project/ustream-ssl.git