aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-08-27 15:49:21 -0700
committerChristian Lamparter <chunkeey@gmail.com>2019-08-31 12:08:23 +0200
commite2ecf39e8e49e43b4d358853f9da51e3897d042c (patch)
tree789dea32236431595a1662fcd2a95122766c4a7d /package/libs
parent075c570cde08c2a27f7e2a64995cc74ae52b5704 (diff)
downloadupstream-e2ecf39e8e49e43b4d358853f9da51e3897d042c.tar.gz
upstream-e2ecf39e8e49e43b4d358853f9da51e3897d042c.tar.bz2
upstream-e2ecf39e8e49e43b4d358853f9da51e3897d042c.zip
ncurses: Do not pass both -fPIC and -fpic
The configure scripts matches Linux with -fPIC, which is not exactly what is desired. Since we are already passing $(FPIC), added a CONFIGURE_VAR to avoid passing -fPIC. Removed PKG_BUILD_DIR as it is already the default value. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/ncurses/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/libs/ncurses/Makefile b/package/libs/ncurses/Makefile
index 8c961f30b2..e22eb2b893 100644
--- a/package/libs/ncurses/Makefile
+++ b/package/libs/ncurses/Makefile
@@ -9,9 +9,8 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ncurses
PKG_VERSION:=6.1
-PKG_RELEASE:=4
+PKG_RELEASE:=5
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
PKG_HASH:=aa057eeeb4a14d470101eff4597d5833dcef5965331be3528c08d99cebaa0d17
@@ -76,6 +75,9 @@ CONFIGURE_ARGS += \
--enable-widec \
--with-build-cppflags=-D_GNU_SOURCE
+CONFIGURE_VARS += \
+ cf_try_fPIC=no
+
HOST_CFLAGS += $(HOST_FPIC)
HOST_CONFIGURE_ARGS += \