aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-12-31 19:37:34 -0800
committerJo-Philipp Wich <jo@mein.io>2020-01-01 16:59:13 +0100
commit1f8ab1c6406451641c05e8cb1e72f7c173a114a3 (patch)
tree0b97a8fa6a01408b896d1c86db8a1f00d3272130 /package/libs
parenta176f8d3ecf09df9d40aaff8271284699695d450 (diff)
downloadupstream-1f8ab1c6406451641c05e8cb1e72f7c173a114a3.tar.gz
upstream-1f8ab1c6406451641c05e8cb1e72f7c173a114a3.tar.bz2
upstream-1f8ab1c6406451641c05e8cb1e72f7c173a114a3.zip
libcxx: Build with the libsupc++ ABI
Allows proper exception handling. This includes removing unimplemented warnings. File size increased as a result: Before: 182874 After: 211006 On mipsel_24kc. Note that this requires libsupc++ anyway. It's specified in g++-libcxx. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libcxx/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/libcxx/Makefile b/package/libs/libcxx/Makefile
index 695b0398fe..60978bdc31 100644
--- a/package/libs/libcxx/Makefile
+++ b/package/libs/libcxx/Makefile
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libcxx
PKG_VERSION:=9.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://git.llvm.org/git/libcxx
@@ -37,6 +37,7 @@ define Package/libcxx/description
endef
CMAKE_OPTIONS += \
+ -DLIBCXX_CXX_ABI="libsupc++" \
-DLIBCXX_ENABLE_ASSERTIONS=OFF \
-DLIBCXX_ENABLE_EXPERIMENTAL_LIBRARY=OFF \
-DLIBCXX_INCLUDE_BENCHMARKS=OFF \