aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-06-14 20:09:29 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-09-04 00:00:38 +0200
commitda9fe5af199f05aeafd63a264a8938e3fff1a1a6 (patch)
tree2bbc737d8bd2b288506430d9c0081546d32d96d7 /package/libs
parent6a4f059ec83132af8c13d39921539b22f5ff8205 (diff)
downloadupstream-da9fe5af199f05aeafd63a264a8938e3fff1a1a6.tar.gz
upstream-da9fe5af199f05aeafd63a264a8938e3fff1a1a6.tar.bz2
upstream-da9fe5af199f05aeafd63a264a8938e3fff1a1a6.zip
libjson-c: add host build (for libblobmsg-json)
Signed-off-by: Daniel Golle <daniel@makrotopia.org> (cherry picked from commit 6fc8e06078d30e8d36a00d0ecc97ac9cc148fe60)
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libjson-c/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index eeb7870f07..60b51146af 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -27,6 +27,7 @@ PKG_INSTALL:=1
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
TARGET_CFLAGS += $(FPIC) -Wno-implicit-fallthrough
@@ -56,3 +57,4 @@ define Package/libjson-c/install
endef
$(eval $(call BuildPackage,libjson-c))
+$(eval $(call HostBuild))