aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:38 +0000
committerJohn Crispin <blogic@openwrt.org>2014-09-01 13:21:38 +0000
commit8af7616f33ef83e8f56a695ce2913b21afaa908d (patch)
treefcbda593d2b29e2cdf2a525cfc9015230e71b14f /package/libs
parent257f026e54f3888e9afa028d10e1c5b7cdd3e23a (diff)
downloadupstream-8af7616f33ef83e8f56a695ce2913b21afaa908d.tar.gz
upstream-8af7616f33ef83e8f56a695ce2913b21afaa908d.tar.bz2
upstream-8af7616f33ef83e8f56a695ce2913b21afaa908d.zip
gmp: add host compile
Currently, any package that uses host compile and depends on libgmp.so will fail. This is because gmp is not compile for host machine. So, staging_dir/host has only static lib for gmp $ ls staging_dir/host/lib/libgmp* -1 staging_dir/host/lib/libgmp.a staging_dir/host/lib/libgmp.la staging_dir/host/lib/libgmpxx.a staging_dir/host/lib/libgmpxx.la Addind host compile in gmp, the dependent package can use: PKG_BUILD_DEPENDS:=gmp/host That will compile gmp to staging_dir/host with *.so files Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com> Backport of r42196 git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@42369 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/gmp/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/gmp/Makefile b/package/libs/gmp/Makefile
index a165131acf..f5839b74bb 100644
--- a/package/libs/gmp/Makefile
+++ b/package/libs/gmp/Makefile
@@ -22,6 +22,7 @@ PKG_FIXUP:=autoreconf
PKG_USE_MIPS16:=0
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
define Package/libgmp
@@ -44,7 +45,6 @@ CONFIGURE_ARGS += \
--without-readline \
--disable-fft \
-
define Build/Compile
$(call Build/Compile/Default, \
DESTDIR="$(PKG_INSTALL_DIR)" \
@@ -66,3 +66,4 @@ define Package/libgmp/install
endef
$(eval $(call BuildPackage,libgmp))
+$(eval $(call HostBuild))