aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-10-09 11:03:00 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-10-09 11:03:00 +0000
commit4452ec99e81296a75c20bce42429ec643d0ae5d3 (patch)
tree687d9acda8ebfc8c928034ef00c24f186f560bfb /package/libs
parent5794387dfad51685ca213d5ba1383c030b09976e (diff)
downloadupstream-4452ec99e81296a75c20bce42429ec643d0ae5d3.tar.gz
upstream-4452ec99e81296a75c20bce42429ec643d0ae5d3.tar.bz2
upstream-4452ec99e81296a75c20bce42429ec643d0ae5d3.zip
[package/libs/libpcap]: IPv6 support should depend on if we've enabled it
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38349 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs')
-rw-r--r--package/libs/libpcap/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index f1d2872254..24b07c932b 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -54,7 +54,6 @@ CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-yydebug \
- --enable-ipv6 \
--with-build-cc="$(HOSTCC)" \
--with-pcap=linux \
--without-septel \
@@ -62,6 +61,11 @@ CONFIGURE_ARGS += \
--without-libnl \
--disable-can
+ifeq ($(CONFIG_IPV6),y)
+CONFIGURE_ARGS += \
+ --enable-ipv6
+endif
+
MAKE_FLAGS += \
CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"