aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/zlib
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-12-12 15:31:59 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-02 17:11:12 +0100
commitcbe71649bc49ccc6ae96385482d0794c33336f68 (patch)
tree94d46b24c57d3040422f049abecaf212802def5a /package/libs/zlib
parent0dd439141da0fc1a7938ee06f7be3924c73ba716 (diff)
downloadupstream-cbe71649bc49ccc6ae96385482d0794c33336f68.tar.gz
upstream-cbe71649bc49ccc6ae96385482d0794c33336f68.tar.bz2
upstream-cbe71649bc49ccc6ae96385482d0794c33336f68.zip
package/libs/zlib: Add host build
Some packages such as Python/Python3 (host pip/pip3) needs this to compile. More detailed explanation provided by Alexandru: "i need the zlib/host for Python/Python3 ; because, it seems the host pip/pip3 needs this to work ; i suspect in older versions this worked, because some of the host's build env would be used in the build, and then the zlib-dev from the host distro would be used ; now, the host-build does not seem to have any -I/usr/include stuff, which is good and it also seems that Python/Python3 does not like it if the zlib-dev package is too old, so using this zlib/host would be good for this as well" Source: https://github.com/lede-project/source/pull/1329#issuecomment-351055861 Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'package/libs/zlib')
-rw-r--r--package/libs/zlib/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libs/zlib/Makefile b/package/libs/zlib/Makefile
index 2650faa139..94977b0589 100644
--- a/package/libs/zlib/Makefile
+++ b/package/libs/zlib/Makefile
@@ -21,6 +21,7 @@ PKG_CPE_ID:=cpe:/a:gnu:zlib
PKG_CONFIG_DEPENDS:= CONFIG_ZLIB_OPTIMIZE_SPEED
+include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -96,5 +97,6 @@ define Package/zlib-dev/install
$(1)/usr/lib/pkgconfig/
endef
+$(eval $(call HostBuild))
$(eval $(call BuildPackage,zlib))
$(eval $(call BuildPackage,zlib-dev))