aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-24 11:53:03 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-25 14:41:40 +0100
commitf6b175a9bfa3a2d9ebc8672eaedf206b41d0f98b (patch)
tree0752e0e4a460f81834ab840eb1b21839cf9ebe33 /package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
parenta75520c678506575ec61ab6c9925364983c5be36 (diff)
downloadupstream-f6b175a9bfa3a2d9ebc8672eaedf206b41d0f98b.tar.gz
upstream-f6b175a9bfa3a2d9ebc8672eaedf206b41d0f98b.tar.bz2
upstream-f6b175a9bfa3a2d9ebc8672eaedf206b41d0f98b.zip
zlib: properly split patches
This package had two patches (with two headers etc.) in one file, which would have quilt merging them during a refresh. Separate these patches into two files, as the original intent seems to be having them separate. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 221eefaf6b301043c491aab8815fcfa24e8a5583)
Diffstat (limited to 'package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch')
-rw-r--r--package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch100
1 files changed, 100 insertions, 0 deletions
diff --git a/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch b/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
new file mode 100644
index 0000000000..68f317b24b
--- /dev/null
+++ b/package/libs/zlib/patches/004-attach-sourcefiles-in-patch-002-to-buildsystem.patch
@@ -0,0 +1,100 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8e75f66..24d7329 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -95,34 +95,67 @@ set(ZLIB_PUBLIC_HDRS
+ ${CMAKE_CURRENT_BINARY_DIR}/zconf.h
+ zlib.h
+ )
+-set(ZLIB_PRIVATE_HDRS
+- crc32.h
+- deflate.h
+- gzguts.h
+- inffast.h
+- inffixed.h
+- inflate.h
+- inftrees.h
+- trees.h
+- zutil.h
+-)
+-set(ZLIB_SRCS
+- adler32.c
+- compress.c
+- crc32.c
+- deflate.c
+- gzclose.c
+- gzlib.c
+- gzread.c
+- gzwrite.c
+- inflate.c
+- infback.c
+- inftrees.c
+- inffast.c
+- trees.c
+- uncompr.c
+- zutil.c
+-)
++
++if(ARMv8)
++ set(ZLIB_PRIVATE_HDRS
++ crc32.h
++ deflate.h
++ gzguts.h
++ inffast.h
++ inffixed.h
++ inflate.h
++ inftrees.h
++ trees.h
++ zutil.h
++ contrib/arm/chunkcopy.h
++ )
++ set(ZLIB_SRCS
++ adler32.c
++ compress.c
++ crc32.c
++ deflate.c
++ gzclose.c
++ gzlib.c
++ gzread.c
++ gzwrite.c
++ infback.c
++ inftrees.c
++ contrib/arm/inflate.c
++ contrib/arm/inffast.c
++ trees.c
++ uncompr.c
++ zutil.c
++ )
++ else()
++ set(ZLIB_PRIVATE_HDRS
++ crc32.h
++ deflate.h
++ gzguts.h
++ inffast.h
++ inffixed.h
++ inflate.h
++ inftrees.h
++ trees.h
++ zutil.h
++ )
++ set(ZLIB_SRCS
++ adler32.c
++ compress.c
++ crc32.c
++ deflate.c
++ gzclose.c
++ gzlib.c
++ gzread.c
++ gzwrite.c
++ inflate.c
++ infback.c
++ inftrees.c
++ inffast.c
++ trees.c
++ uncompr.c
++ zutil.c
++ )
++endif()
+
+ if(NOT MINGW)
+ set(ZLIB_DLL_SRCS