aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/uclibc++/patches/010-honor-ldflags.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-04-06 23:37:56 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:10:10 +0200
commit0b2638253321db90e9844f04cd7299c1a2e1633a (patch)
tree0fd3af340c492fc4f201c3eec3e9e9659ce32cc8 /package/libs/uclibc++/patches/010-honor-ldflags.patch
parente49b6bb61828b8b903db0ef48113b4065a215c63 (diff)
downloadupstream-0b2638253321db90e9844f04cd7299c1a2e1633a.tar.gz
upstream-0b2638253321db90e9844f04cd7299c1a2e1633a.tar.bz2
upstream-0b2638253321db90e9844f04cd7299c1a2e1633a.zip
uClibc++: Update to 0.2.5
Switched to xz archives for smaller size. Removed upstreamed patches. Reorganized Makefile a little bit for clarity. Build/Prepare is not useful anymore. Upstream converted the file to LF. Refreshed config. Removed -ansi option from the original CFLAGS as this was causing long long support to be missing. Removed fPIC. We have the macro $(FPIC) already used. No point in setting fpic and fPIC together. Removed pedantic -Wlong-long warnings as they are not useful. Removed -std=gnu++98. Not only is it unnecessary (it compiles against all standards), it actually results in a size increase. 75843 vs. 75222 (gcc in OpenWrt defaults to g++14). Added --gc-sections to linker flags to reduce size: 72653 vs 75222. Removed warn linker options. They have been upstreamed. Tested on Archer C7v2 and GnuBee PC1. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/uclibc++/patches/010-honor-ldflags.patch')
-rw-r--r--package/libs/uclibc++/patches/010-honor-ldflags.patch23
1 files changed, 0 insertions, 23 deletions
diff --git a/package/libs/uclibc++/patches/010-honor-ldflags.patch b/package/libs/uclibc++/patches/010-honor-ldflags.patch
deleted file mode 100644
index b1050cb1bd..0000000000
--- a/package/libs/uclibc++/patches/010-honor-ldflags.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -3,9 +3,9 @@ include $(TOPDIR)Rules.mak
-
- WR_CXX := WRAPPER_INCLUDEDIR=-I$(TOPDIR)include $(TOPDIR)bin/g++-uc
-
--LDFLAGS += -nodefaultlibs -shared -Wl,-soname,$(SHARED_MAJORNAME) $(BUILD_EXTRA_LIBRARIES)
-+EXTRA_LDFLAGS += -nodefaultlibs -shared -Wl,-soname,$(SHARED_MAJORNAME) $(BUILD_EXTRA_LIBRARIES)
- ifneq ($(DODEBUG),y)
--LDFLAGS += -Wl,-s
-+EXTRA_LDFLAGS += -Wl,-s
- endif
-
- SRCS = $(wildcard *.cpp)
-@@ -60,7 +60,7 @@ $(LIBNAME).a: libgcc_eh libsupc $(EXOBJS
- $(RANLIB) $@
-
- $(SHARED_FULLNAME): libgcc_eh libsupc $(EXOBJS)
-- $(CC) $(LDFLAGS) -o $@ $(EXOBJS) $(SUPOBJS) $(GCCOBJS) $(LIBS)
-+ $(CC) $(LDFLAGS) $(EXTRA_LDFLAGS) -o $@ $(EXOBJS) $(SUPOBJS) $(GCCOBJS) $(LIBS)
- $(LN) $@ $(SHARED_MAJORNAME)
- $(LN) $(SHARED_MAJORNAME) $(LIBNAME).so
-