aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl
diff options
context:
space:
mode:
authorEneas U de Queiroz <cotequeiroz@gmail.com>2023-03-06 11:58:56 -0300
committerEneas U de Queiroz <cotequeiroz@gmail.com>2023-03-06 18:11:36 -0300
commitc75cd5f6028da6ceb1fb3438da93e2305cd720b1 (patch)
treecae80f69a74e9ea0c3e0e3bed208da599ac47ee5 /package/libs/openssl
parent387c2df15cbd7bfa3917209541e1cd94ddc885d0 (diff)
downloadupstream-c75cd5f6028da6ceb1fb3438da93e2305cd720b1.tar.gz
upstream-c75cd5f6028da6ceb1fb3438da93e2305cd720b1.tar.bz2
upstream-c75cd5f6028da6ceb1fb3438da93e2305cd720b1.zip
openssl: fix variable reference in conffiles
Fix the trivial abscence of $() when assigning engine config files to the main libopenssl-config package even if the corresponding engines were not built into the main library. This is mostly cosmetic, since scripts/ipkg-build tests the file's presence before it is actually included in the package's conffiles. Fixes: 30b0351039 "openssl: configure engine packages during install" Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
Diffstat (limited to 'package/libs/openssl')
-rw-r--r--package/libs/openssl/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 90aaafd31f..57ff056e90 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=3.0.8
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
@@ -128,8 +128,8 @@ endef
define Package/libopenssl-conf/conffiles
/etc/ssl/openssl.cnf
-$(if CONFIG_OPENSSL_ENGINE_BUILTIN_DEVCRYPTO,/etc/ssl/engines.cnf.d/devcrypto.cnf)
-$(if CONFIG_OPENSSL_ENGINE_BUILTIN_PADLOCK,/etc/ssl/engines.cnf.d/padlock.cnf)
+$(if $(CONFIG_OPENSSL_ENGINE_BUILTIN_DEVCRYPTO),/etc/ssl/engines.cnf.d/devcrypto.cnf)
+$(if $(CONFIG_OPENSSL_ENGINE_BUILTIN_PADLOCK),/etc/ssl/engines.cnf.d/padlock.cnf)
endef
define Package/libopenssl-conf/description