aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/patches/200-parallel_build.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2015-12-03 21:08:28 +0000
committerHauke Mehrtens <hauke@openwrt.org>2015-12-03 21:08:28 +0000
commit9857f5d8440baaa3341f9f0334ae8a424398e65f (patch)
tree0bf13a78a6c16b9e8ffdb6f2dcdc9f0ce9528ee0 /package/libs/openssl/patches/200-parallel_build.patch
parentab5f4ad6ce6b213cdc6bd73ba89fd9fef304cef5 (diff)
downloadupstream-9857f5d8440baaa3341f9f0334ae8a424398e65f.tar.gz
upstream-9857f5d8440baaa3341f9f0334ae8a424398e65f.tar.bz2
upstream-9857f5d8440baaa3341f9f0334ae8a424398e65f.zip
CC: openssl: update to version 1.0.2e
backport of r47726. This fixes the following security problems: * CVE-2015-3193 * CVE-2015-3194 * CVE-2015-3195) Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47727 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/patches/200-parallel_build.patch')
-rw-r--r--package/libs/openssl/patches/200-parallel_build.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/libs/openssl/patches/200-parallel_build.patch b/package/libs/openssl/patches/200-parallel_build.patch
index c3fc3f3b4c..edb201a458 100644
--- a/package/libs/openssl/patches/200-parallel_build.patch
+++ b/package/libs/openssl/patches/200-parallel_build.patch
@@ -1,6 +1,6 @@
--- a/Makefile.org
+++ b/Makefile.org
-@@ -278,17 +278,17 @@ build_libcrypto: build_crypto build_engi
+@@ -280,17 +280,17 @@ build_libcrypto: build_crypto build_engi
build_libssl: build_ssl libssl.pc
build_crypto:
@@ -24,7 +24,7 @@
all_testapps: build_libs build_testapps
build_testapps:
-@@ -460,7 +460,7 @@ update: errors stacks util/libeay.num ut
+@@ -462,7 +462,7 @@ update: errors stacks util/libeay.num ut
@set -e; target=update; $(RECURSIVE_BUILD_CMD)
depend:
@@ -33,7 +33,7 @@
lint:
@set -e; target=lint; $(RECURSIVE_BUILD_CMD)
-@@ -522,9 +522,9 @@ dist:
+@@ -527,9 +527,9 @@ dist:
dist_pem_h:
(cd crypto/pem; $(MAKE) -e $(BUILDENV) pem.h; $(MAKE) clean)
@@ -45,7 +45,7 @@
@$(PERL) $(TOP)/util/mkdir-p.pl $(INSTALL_PREFIX)$(INSTALLTOP)/bin \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR) \
$(INSTALL_PREFIX)$(INSTALLTOP)/$(LIBDIR)/engines \
-@@ -533,12 +533,19 @@ install_sw:
+@@ -538,12 +538,19 @@ install_sw:
$(INSTALL_PREFIX)$(OPENSSLDIR)/misc \
$(INSTALL_PREFIX)$(OPENSSLDIR)/certs \
$(INSTALL_PREFIX)$(OPENSSLDIR)/private
@@ -66,7 +66,7 @@
@set -e; liblist="$(LIBS)"; for i in $$liblist ;\
do \
if [ -f "$$i" ]; then \
-@@ -622,12 +629,7 @@ install_html_docs:
+@@ -627,12 +634,7 @@ install_html_docs:
done; \
done
@@ -164,7 +164,7 @@
ctags $(SRC)
--- a/test/Makefile
+++ b/test/Makefile
-@@ -134,7 +134,7 @@ install:
+@@ -138,7 +138,7 @@ install:
tags:
ctags $(SRC)
@@ -173,7 +173,7 @@
apps:
@(cd ..; $(MAKE) DIRS=apps all)
-@@ -538,7 +538,7 @@ $(VERIFYEXTRATEST)$(EXE_EXT): $(VERIFYEX
+@@ -549,7 +549,7 @@ $(CLIENTHELLOTEST)$(EXE_EXT): $(CLIENTHE
# fi
dummytest$(EXE_EXT): dummytest.o $(DLIBCRYPTO)