aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-09 13:19:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-09 13:19:29 +0000
commitd11fe14771016c8e913835284f82d8acf357a7b3 (patch)
tree8163ac9edc2921613c621a3f9c9e49b3ef651cd8 /package/libs/openssl/Makefile
parent3e05d1f90f878ebd2a7e2882c57296dc419a3560 (diff)
downloadupstream-d11fe14771016c8e913835284f82d8acf357a7b3.tar.gz
upstream-d11fe14771016c8e913835284f82d8acf357a7b3.tar.bz2
upstream-d11fe14771016c8e913835284f82d8acf357a7b3.zip
openssl: detect configuration changes and clean build tree accordingly (fixes #15067)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39852 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index fe99a534b8..38679acb2b 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -110,7 +110,13 @@ else
endif
endif
+STAMP_CONFIGURED := $(STAMP_CONFIGURED)_$(subst $(space),_,$(OPENSSL_OPTIONS))
+
define Build/Configure
+ [ -f $(STAMP_CONFIGURED) ] || { \
+ rm -f $(PKG_BUILD_DIR)/*.so.* $(PKG_BUILD_DIR)/*.a; \
+ find $(PKG_BUILD_DIR) -name \*.o | xargs rm -f; \
+ }
(cd $(PKG_BUILD_DIR); \
./Configure $(OPENSSL_TARGET) \
--prefix=/usr \