aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-12-14 10:19:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-12-14 10:19:48 +0000
commit95758e8d2c729d4aa76b56f54a26397a6eb9336f (patch)
tree8bcecb5797bcafc15982e1b55aaf30cec09d9fdd /package/libs/openssl/Makefile
parent6a75a79a668b7d8121031bbdcb51df4d276e8f33 (diff)
downloadupstream-95758e8d2c729d4aa76b56f54a26397a6eb9336f.tar.gz
upstream-95758e8d2c729d4aa76b56f54a26397a6eb9336f.tar.bz2
upstream-95758e8d2c729d4aa76b56f54a26397a6eb9336f.zip
openssl: Support multi-threaded applications
Allow multi-threaded applications to work properly by removing the "no-threads" flag that is enabled by default. Signed-off-by: Sujith Manoharan <c_manoha@qca.qualcomm.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39048 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 27b6e99e3b..f2898371c8 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -79,7 +79,7 @@ endef
OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc5 no-sha0 no-smime \
no-aes192 no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-err no-hw no-threads zlib-dynamic no-sse2
+OPENSSL_OPTIONS:= shared no-err no-hw zlib-dynamic no-sse2
ifdef CONFIG_OPENSSL_ENGINE_CRYPTO
OPENSSL_OPTIONS += -DHAVE_CRYPTODEV