aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-05-10 00:18:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-05-10 00:18:27 +0000
commit51274528ebd91ef1c5c16a3752a16cf1e6dea8ea (patch)
tree91441e84ea8398e8733ffa23bb3459861b0af733 /package/libs/openssl/Makefile
parentd77b46ba2547fbd01b14f526936817d1134d1a54 (diff)
downloadupstream-51274528ebd91ef1c5c16a3752a16cf1e6dea8ea.tar.gz
upstream-51274528ebd91ef1c5c16a3752a16cf1e6dea8ea.tar.bz2
upstream-51274528ebd91ef1c5c16a3752a16cf1e6dea8ea.zip
openssl: disable mips16, it makes the code slower
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36602 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 049aad44a8..0091579985 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -111,7 +111,7 @@ define Build/Configure
)
endef
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS := $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS)) $(FPIC)
define Build/Compile
# XXX: OpenSSL "make depend" will look for installed headers before its own,