aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-09 13:19:25 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-09 13:19:25 +0000
commit3e05d1f90f878ebd2a7e2882c57296dc419a3560 (patch)
treebd993e18bc3126438a50bb8b2643833ae11c7926 /package/libs/openssl/Makefile
parenta4c810d32b1597bbd5d27d1ee43dbff7ebacc017 (diff)
downloadupstream-3e05d1f90f878ebd2a7e2882c57296dc419a3560.tar.gz
upstream-3e05d1f90f878ebd2a7e2882c57296dc419a3560.tar.bz2
upstream-3e05d1f90f878ebd2a7e2882c57296dc419a3560.zip
openssl: move make depend call to Build/Configure
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39851 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 19863fbf58..fe99a534b8 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -121,11 +121,6 @@ define Build/Configure
$(OPENSSL_NO_CIPHERS) \
$(OPENSSL_OPTIONS) \
)
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
# XXX: OpenSSL "make depend" will look for installed headers before its own,
# so remove installed stuff first
-$(SUBMAKE) -j1 clean-staging
@@ -134,6 +129,11 @@ define Build/Compile
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
$(OPENSSL_MAKEFLAGS) \
depend
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
ASFLAGS="$(TARGET_ASFLAGS) -c" \