aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-08-14 13:02:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-08-14 13:02:33 +0000
commit2d1f470204b986e572cafc55e900db7ab536afcb (patch)
tree3e2bcb695266010c1500a6130688090c523521a2 /package/libs/openssl/Makefile
parent64584aa1fcecfa733e4ef83d294280bce9f2922b (diff)
downloadupstream-2d1f470204b986e572cafc55e900db7ab536afcb.tar.gz
upstream-2d1f470204b986e572cafc55e900db7ab536afcb.tar.bz2
upstream-2d1f470204b986e572cafc55e900db7ab536afcb.zip
openssl: to disable mips16, use the new PKG_USE_MIPS16 flag instead of messing with cflags directly
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37771 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 8b0f5243bb..8f4f93d852 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -10,6 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=1.0.1e
PKG_RELEASE:=2
+PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -120,7 +121,7 @@ define Build/Configure
)
endef
-TARGET_CFLAGS := $(filter-out -mips16 -minterlink-mips16,$(TARGET_CFLAGS)) $(FPIC)
+TARGET_CFLAGS += $(FPIC)
define Build/Compile
# XXX: OpenSSL "make depend" will look for installed headers before its own,