aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-03-12 10:00:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-03-12 10:00:53 +0000
commit29368b6958cb725ac965a4a9089d3251b65a561f (patch)
tree6b545b5a1305d81855899388af24d9d094f606dc /package/libs/openssl/Makefile
parente7e3c5ac9adb036c6599f7dfeb699aae7886e931 (diff)
downloadupstream-29368b6958cb725ac965a4a9089d3251b65a561f.tar.gz
upstream-29368b6958cb725ac965a4a9089d3251b65a561f.tar.bz2
upstream-29368b6958cb725ac965a4a9089d3251b65a561f.zip
openssl: Fix x86_64 build on some 64bit host systems
On some build hosts openssl fails to install since openssl installs itself into lib64 while the openwrt Makefile expects the libs to end up in lib. install -m0644 .../openwrt/build_dir/target-x86_64_uClibc-0.9.33.2/openssl-1.0.1e/ipkg-install/usr/lib/libcrypto.so.* .../openwrt/build_dir/target-x86_64_uClibc-0.9.33.2/openssl-1.0.1e/ipkg-x86_64/libopenssl/usr/lib/ install: cannot stat '.../openwrt/build_dir/target-x86_64_uClibc-0.9.33.2/openssl-1.0.1e/ipkg-install/usr/lib/libcrypto.so.*': No such file or directory make[2]: *** [/openwrt/bin/x86_64/packages/libopenssl_1.0.1e-2_x86_64.ipk] Error 1 make[2]: Leaving directory `/openwrt/package/libs/openssl' make[1]: *** [package/libs/openssl/compile] Error 2 make[1]: Leaving directory `/openwrt' Set LIBDIR accordingly to fix this. Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39885 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 8a8e8520d4..39fc513495 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -100,6 +100,7 @@ endif
ifeq ($(CONFIG_x86_64),y)
OPENSSL_TARGET:=linux-x86_64
+ OPENSSL_MAKEFLAGS += LIBDIR=lib
else
OPENSSL_OPTIONS+=no-sse2
ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)