aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/musl-fts
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-09-23 23:44:57 -0700
committerChristian Lamparter <chunkeey@gmail.com>2022-03-27 14:38:13 +0200
commit8a75ed4ba07b9d64ae547ce36873e51ba54f0eaf (patch)
tree8cdc303abc05fdd3229a0b9a5dc5c8edc76819f2 /package/libs/musl-fts
parent1562e430d44fb474a9a1f03845d59855172aded4 (diff)
downloadupstream-8a75ed4ba07b9d64ae547ce36873e51ba54f0eaf.tar.gz
upstream-8a75ed4ba07b9d64ae547ce36873e51ba54f0eaf.tar.bz2
upstream-8a75ed4ba07b9d64ae547ce36873e51ba54f0eaf.zip
musl-fts: remove shared libraries from host
Avoids having to add rpath to the various packages using it. Also add PIC to fix compilation as static libraries do not use PIC by default. Fixes: 1fb099341e58 ("musl-fts: add host build") Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/musl-fts')
-rw-r--r--package/libs/musl-fts/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/libs/musl-fts/Makefile b/package/libs/musl-fts/Makefile
index e913fe167f..72341cd379 100644
--- a/package/libs/musl-fts/Makefile
+++ b/package/libs/musl-fts/Makefile
@@ -44,6 +44,7 @@ define Package/musl-fts/description
The musl-fts package implements the fts(3) functions fts_open, fts_read, fts_children, fts_set and fts_close, which are missing in musl libc.
endef
+HOST_CONFIGURE_ARGS += --disable-shared --with-pic
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include