aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/mbedtls/patches/300-soversion-compatibility.patch
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-06-02 12:36:18 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-06-18 20:45:43 +0200
commit076ea9f473198363d2bd4b4702c4922ab9c9fafa (patch)
treeaf069cbf0a0e5e228a00248e088bf395d81d4eef /package/libs/mbedtls/patches/300-soversion-compatibility.patch
parent6c5c3a2edccfeedffdbd2634895778685f17bd2e (diff)
downloadupstream-076ea9f473198363d2bd4b4702c4922ab9c9fafa.tar.gz
upstream-076ea9f473198363d2bd4b4702c4922ab9c9fafa.tar.bz2
upstream-076ea9f473198363d2bd4b4702c4922ab9c9fafa.zip
mbedtls: update to version 2.7.10
This fixes multiple bugs and this security problem: * CVE-2018-19608 Local timing attack on RSA decryption Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/libs/mbedtls/patches/300-soversion-compatibility.patch')
-rw-r--r--package/libs/mbedtls/patches/300-soversion-compatibility.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/libs/mbedtls/patches/300-soversion-compatibility.patch b/package/libs/mbedtls/patches/300-soversion-compatibility.patch
index dc957871ea..31b47ad1a5 100644
--- a/package/libs/mbedtls/patches/300-soversion-compatibility.patch
+++ b/package/libs/mbedtls/patches/300-soversion-compatibility.patch
@@ -4,12 +4,12 @@ the new library with binaries compiled against the old library.
--- a/library/CMakeLists.txt
+++ b/library/CMakeLists.txt
-@@ -141,7 +141,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
+@@ -147,7 +147,7 @@ endif(USE_STATIC_MBEDTLS_LIBRARY)
if(USE_SHARED_MBEDTLS_LIBRARY)
add_library(mbedcrypto SHARED ${src_crypto})
-- set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.5 SOVERSION 2)
-+ set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.5 SOVERSION 0)
+- set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.10 SOVERSION 2)
++ set_target_properties(mbedcrypto PROPERTIES VERSION 2.7.10 SOVERSION 0)
target_link_libraries(mbedcrypto ${libs})
add_library(mbedx509 SHARED ${src_x509})