aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/mbedtls/Makefile
diff options
context:
space:
mode:
authorMagnus Kroken <mkroken@gmail.com>2020-07-25 14:19:28 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-27 00:28:00 +0200
commit19b8696dd7e6e1c4c2a66bbfe32df08b24ed0ca6 (patch)
treef85a843b133560772fe335602029e7632fd8dddc /package/libs/mbedtls/Makefile
parenta2a75c21bdb1afc6786d01693c8a52f34197ea9b (diff)
downloadupstream-19b8696dd7e6e1c4c2a66bbfe32df08b24ed0ca6.tar.gz
upstream-19b8696dd7e6e1c4c2a66bbfe32df08b24ed0ca6.tar.bz2
upstream-19b8696dd7e6e1c4c2a66bbfe32df08b24ed0ca6.zip
mbedtls: update to 2.16.7
Mbed TLS 2.16.7 is a maintenance release of the Mbed TLS 2.16 branch, and provides bug fixes and minor enhancements. This release includes fixes for security issues and the most severe one is described in more detail in a security advisory: https://tls.mbed.org/tech-updates/security-advisories/mbedtls-security-advisory-2020-07 * Fix a side channel vulnerability in modular exponentiation that could reveal an RSA private key used in a secure enclave. * Fix side channel in mbedtls_ecp_check_pub_priv() and mbedtls_pk_parse_key() / mbedtls_pk_parse_keyfile() (when loading a private key that didn't include the uncompressed public key), as well as mbedtls_ecp_mul() / mbedtls_ecp_mul_restartable() when called with a NULL f_rng argument. An attacker with access to precise enough timing and memory access information (typically an untrusted operating system attacking a secure enclave) could fully recover the ECC private key. * Fix issue in Lucky 13 counter-measure that could make it ineffective when hardware accelerators were used (using one of the MBEDTLS_SHAxxx_ALT macros). Due to Mbed TLS moving from ARMmbed to the Trusted Firmware project, some changes to the download URLs are required. For the time being, the ARMmbed/mbedtls Github repository is the canonical source for Mbed TLS. Signed-off-by: Magnus Kroken <mkroken@gmail.com> [Use https://codeload.github.com and new tar.gz file] Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> (cherry picked from commit 201d6776a0b5858b8ce43a2392c9fe48aa1c4dd7)
Diffstat (limited to 'package/libs/mbedtls/Makefile')
-rw-r--r--package/libs/mbedtls/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/libs/mbedtls/Makefile b/package/libs/mbedtls/Makefile
index 978d5ca19a..8e14773e78 100644
--- a/package/libs/mbedtls/Makefile
+++ b/package/libs/mbedtls/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mbedtls
-PKG_VERSION:=2.16.6
+PKG_VERSION:=2.16.7
PKG_RELEASE:=1
PKG_USE_MIPS16:=0
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
-PKG_SOURCE_URL:=https://tls.mbed.org/download/
-PKG_HASH:=80a484df42f32dbe95665cd4b18ce0dd14b6c67dfd561d36d1475802e41eb3ed
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/ARMmbed/mbedtls/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=c95b11557ee97d2bdfd48cd57cf9b648a6cddd2ca879e3c35c4e7525f2871992
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0+