aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libxml2/patches
diff options
context:
space:
mode:
authorMichael Pratt <mcpratt@pm.me>2023-04-19 12:52:04 -0400
committerChristian Marangi <ansuelsmth@gmail.com>2023-05-04 06:07:29 +0200
commit9b0b46985c112c664354dc745d8cfb313166744b (patch)
tree0b8999b6e94ec3d2dc91a56e374d24a1b7613c29 /package/libs/libxml2/patches
parent2070a2ca27bdb2b1e4e1587274e192e42f247516 (diff)
downloadupstream-9b0b46985c112c664354dc745d8cfb313166744b.tar.gz
upstream-9b0b46985c112c664354dc745d8cfb313166744b.tar.bz2
upstream-9b0b46985c112c664354dc745d8cfb313166744b.zip
libxml2: add from packages feed
Add libxml2 which can be used to build gettext instead of the old built-in substitute for it. Signed-off-by: Michael Pratt <mcpratt@pm.me>
Diffstat (limited to 'package/libs/libxml2/patches')
-rw-r--r--package/libs/libxml2/patches/010-iconv.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/libs/libxml2/patches/010-iconv.patch b/package/libs/libxml2/patches/010-iconv.patch
new file mode 100644
index 0000000000..e35b7ce939
--- /dev/null
+++ b/package/libs/libxml2/patches/010-iconv.patch
@@ -0,0 +1,12 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -496,6 +496,9 @@ if(LIBXML2_WITH_PROGRAMS)
+ add_executable(LibXml2::${PROGRAM} ALIAS ${PROGRAM})
+ target_compile_definitions(${PROGRAM} PRIVATE SYSCONFDIR="${CMAKE_INSTALL_FULL_SYSCONFDIR}")
+ target_link_libraries(${PROGRAM} LibXml2)
++ if(LIBXML2_WITH_ICONV AND NOT Iconv_IS_BUILT_IN)
++ target_link_libraries(${PROGRAM} iconv)
++ endif()
+ if(HAVE_LIBHISTORY)
+ target_link_libraries(${PROGRAM} history)
+ endif()