aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libusb-compat/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-11-24 22:26:17 -0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-11-25 13:23:06 +0100
commita058349ff935ce49c153414b994b04b488d918df (patch)
tree6c7e39bcd02e3c98fb83c5e8449ea454d0acb7cc /package/libs/libusb-compat/Makefile
parent2418657104e5e0056d76b1840d1b2dba8db43127 (diff)
downloadupstream-a058349ff935ce49c153414b994b04b488d918df.tar.gz
upstream-a058349ff935ce49c153414b994b04b488d918df.tar.bz2
upstream-a058349ff935ce49c153414b994b04b488d918df.zip
libusb-compat: remove
No package in base relies on this library. This library will be moved to packages where it is needed. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/libusb-compat/Makefile')
-rw-r--r--package/libs/libusb-compat/Makefile54
1 files changed, 0 insertions, 54 deletions
diff --git a/package/libs/libusb-compat/Makefile b/package/libs/libusb-compat/Makefile
deleted file mode 100644
index 5f9b2385c8..0000000000
--- a/package/libs/libusb-compat/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-#
-# Copyright (C) 2010-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libusb-compat
-PKG_VERSION:=0.1.5
-PKG_RELEASE:=2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/libusb
-PKG_HASH:=404ef4b6b324be79ac1bfb3d839eac860fbc929e6acb1ef88793a6ea328bc55a
-
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-PKG_LICENSE:=LGPL-2.1
-
-PKG_MAINTAINER := Felix Fietkau <nbd@nbd.name>
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/libusb-compat
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=libusb-0.1 compatibility library
- DEPENDS:=+libusb-1.0
- URL:=http://libusb.wiki.sourceforge.net/
- ABI_VERSION:=4
-endef
-
-define Package/libusb-compat/description
- libusb is a C library that gives applications easy access to USB devices on
- many different operating systems.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)
- $(CP) $(PKG_INSTALL_DIR)/* $(1)/
- $(INSTALL_DIR) $(2)/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/libusb-config $(2)/bin/
-endef
-
-define Package/libusb-compat/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusb-0.1.so* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,libusb-compat))