aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libtool
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-22 00:28:54 +0100
committerJo-Philipp Wich <jo@mein.io>2017-02-01 16:05:52 +0100
commitd1d970e2352072ec06599b9024df107ac1b96f5d (patch)
treec567925403e6e935c5a9e03dc29732d11714ba44 /package/libs/libtool
parente5bc7bff85ba436f8ad4a1012b15d06d396f0b01 (diff)
downloadupstream-d1d970e2352072ec06599b9024df107ac1b96f5d.tar.gz
upstream-d1d970e2352072ec06599b9024df107ac1b96f5d.tar.bz2
upstream-d1d970e2352072ec06599b9024df107ac1b96f5d.zip
libtool: don't clobber host libtool infrastructure
The libtool target package stages its files into the host staging directory and moves the libltdl library parts from there into the target staging directory afterwards. By doing so, the package essentially renders the host libtool infrastructure unusable, leading to the below error in subsequent package builds: libtoolize: $pkgltdldir is not a directory: `.../hostpkg/share/libtool` Prevent this problem by using a dedicated libltdl install prefix in order to avoid overwriting and moving away preexisting files belonging to tools/libtool. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/libtool')
-rw-r--r--package/libs/libtool/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/libs/libtool/Makefile b/package/libs/libtool/Makefile
index 2d5cedf786..5eb521a72b 100644
--- a/package/libs/libtool/Makefile
+++ b/package/libs/libtool/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libtool
PKG_VERSION:=2.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/libtool
@@ -34,14 +34,14 @@ endef
define Build/InstallDev
$(MAKE) -C $(PKG_BUILD_DIR) \
- bindir="$(2)/bin" \
- datadir="$(2)/share" \
- prefix="$(2)" \
- exec_prefix="$(2)" \
+ bindir="$(2)/libltdl/bin" \
+ datadir="$(2)/libltdl/share" \
+ prefix="$(2)/libltdl" \
+ exec_prefix="$(2)/libltdl" \
install
$(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
- mv $(2)/lib/* $(1)/usr/lib/
- mv $(2)/include/* $(1)/usr/include/
+ mv $(2)/libltdl/lib/* $(1)/usr/lib/
+ mv $(2)/libltdl/include/* $(1)/usr/include/
endef
define Package/libltdl/install