aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libpcap
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2020-05-06 00:47:55 +0200
committerJo-Philipp Wich <jo@mein.io>2020-05-06 00:51:35 +0200
commit429e4490c4a325de5459b5d236633586be38cde7 (patch)
tree46f62b1070c1f5dec7b3771edf5851ff2f11bcc3 /package/libs/libpcap
parente678cb15956e99adb3f1b970271824f42a392fbe (diff)
downloadupstream-429e4490c4a325de5459b5d236633586be38cde7.tar.gz
upstream-429e4490c4a325de5459b5d236633586be38cde7.tar.bz2
upstream-429e4490c4a325de5459b5d236633586be38cde7.zip
libpcap: fix library packaging issues
Workaround a bug in patches/100-debian_shared_lib.patch - it attemptss to extract the library major version from debian/changelog which does not exist in the vanilla upstream tarball. Create a fake changelog file for now to satisfy the version extraction routine until we get around to properly augment the patch. Fixes: FS#2970 Fixes: 96ee7c8bfd ("libpcap: Update shared-lib patch from Debian to fix linking problems") Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/libpcap')
-rw-r--r--package/libs/libpcap/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index e6d9ee75b3..c42fa86cdd 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpcap
PKG_VERSION:=1.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=2.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
@@ -84,6 +84,10 @@ define Build/Configure
$(if $(CONFIG_PCAP_HAS_USB),,$(SED) 's/pcap-usb-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
$(if $(CONFIG_PCAP_HAS_BT),,$(SED) '/^#define PCAP_SUPPORT_BT/D' $(PKG_BUILD_DIR)/config.h)
$(if $(CONFIG_PCAP_HAS_BT),,$(SED) 's/pcap-bt-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
+
+ # Workaround https://bugs.openwrt.org/index.php?do=details&task_id=2970
+ mkdir $(PKG_BUILD_DIR)/debian
+ echo "libpcap (1-0)" > $(PKG_BUILD_DIR)/debian/changelog
endef
define Build/InstallDev