aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libpcap/patches/100-debian_shared_lib.patch
diff options
context:
space:
mode:
authorSyrone Wong <wong.syrone@gmail.com>2018-07-26 22:46:38 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2019-10-19 15:25:45 +0200
commita857fc2ded37aec2b9f743087a7752bb3c0b510b (patch)
tree44c64aef873f434f9deb53f0c6b8647de73d653c /package/libs/libpcap/patches/100-debian_shared_lib.patch
parent31181fa06288189834a945b0e3d71c9823b481a1 (diff)
downloadupstream-a857fc2ded37aec2b9f743087a7752bb3c0b510b.tar.gz
upstream-a857fc2ded37aec2b9f743087a7752bb3c0b510b.tar.bz2
upstream-a857fc2ded37aec2b9f743087a7752bb3c0b510b.zip
libpcap: update to 1.9.0
001-Fix-compiler_state_t.ai-usage-when-INET6-is-not-defi.patch dropped due to upstream 002-Add-missing-compiler_state_t-parameter.patch dropped due to upstream 202-protocol_api.patch dropped due to implemented upstream by another way upstream commit: https://github.com/the-tcpdump-group/libpcap/commit/55c690f6f834b4762697d7a134de439c9096c921 and renamed via: https://github.com/the-tcpdump-group/libpcap/commit/697b1f7e9b1d6f5a5be04f821d7c5dc62458bb3b ead is the only user who use the protocol api, we have to use the new api since libpcap 1.9.0 Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Diffstat (limited to 'package/libs/libpcap/patches/100-debian_shared_lib.patch')
-rw-r--r--package/libs/libpcap/patches/100-debian_shared_lib.patch81
1 files changed, 37 insertions, 44 deletions
diff --git a/package/libs/libpcap/patches/100-debian_shared_lib.patch b/package/libs/libpcap/patches/100-debian_shared_lib.patch
index 59d15e6602..9eb38dde7e 100644
--- a/package/libs/libpcap/patches/100-debian_shared_lib.patch
+++ b/package/libs/libpcap/patches/100-debian_shared_lib.patch
@@ -3,7 +3,7 @@ build a shared library.
--- a/Makefile.in
+++ b/Makefile.in
-@@ -38,6 +38,13 @@ mandir = @mandir@
+@@ -40,6 +40,13 @@ mandir = @mandir@
srcdir = @srcdir@
VPATH = @srcdir@
@@ -17,17 +17,17 @@ build a shared library.
#
# You shouldn't need to edit anything below.
#
-@@ -62,7 +69,8 @@ DEPENDENCY_CFLAG = @DEPENDENCY_CFLAG@
- PROG=libpcap
+@@ -69,7 +76,8 @@ INSTALL_RPCAPD=@INSTALL_RPCAPD@
+ EXTRA_NETWORK_LIBS=@EXTRA_NETWORK_LIBS@
- # Standard CFLAGS
--FULL_CFLAGS = $(CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
-+FULL_CFLAGS = $(CCOPT) $(INCLS) $(DEFS) $(CFLAGS) $(CPPFLAGS)
+ # Standard CFLAGS for building members of a shared library
+-FULL_CFLAGS = $(CCOPT) $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS)
++FULL_CFLAGS = $(CCOPT) $(SHLIB_CCOPT) $(INCLS) $(DEFS) $(CFLAGS) $(CPPFLAGS)
+CFLAGS_SHARED = -shared -Wl,-soname,$(SHAREDLIB)
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -77,7 +85,11 @@ YACC = @YACC@
+@@ -84,7 +92,11 @@ YACC = @YACC@
# problem if you don't own the file but can write to the directory.
.c.o:
@rm -f $@
@@ -38,9 +38,9 @@ build a shared library.
+ @rm -f $@
+ $(CC) -fPIC $(FULL_CFLAGS) -c -o $@ $(srcdir)/$*.c
- PSRC = pcap-@V_PCAP@.c @USB_SRC@ @BT_SRC@ @BT_MONITOR_SRC@ @NETFILTER_SRC@ @DBUS_SRC@
+ PSRC = pcap-@V_PCAP@.c @USB_SRC@ @BT_SRC@ @BT_MONITOR_SRC@ @NETFILTER_SRC@ @DBUS_SRC@ @NETMAP_SRC@ @RDMA_SRC@
FSRC = @V_FINDALLDEVS@
-@@ -93,6 +105,7 @@ SRC = $(PSRC) $(FSRC) $(CSRC) $(SSRC) $(
+@@ -101,6 +113,7 @@ SRC = $(PSRC) $(FSRC) $(CSRC) $(SSRC) $(
# We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
# hack the extra indirection
OBJ = $(PSRC:.c=.o) $(FSRC:.c=.o) $(CSRC:.c=.o) $(SSRC:.c=.o) $(GENSRC:.c=.o) $(LIBOBJS)
@@ -48,16 +48,16 @@ build a shared library.
PUBHDR = \
pcap.h \
pcap-bpf.h \
-@@ -157,7 +170,7 @@ TAGFILES = \
+@@ -154,7 +167,7 @@ TAGFILES = \
- CLEANFILES = $(OBJ) libpcap.* $(TESTS) \
+ CLEANFILES = $(OBJ) libpcap.a libpcap.so.`cat $(srcdir)/VERSION` \
$(PROG)-`cat $(srcdir)/VERSION`.tar.gz $(GENSRC) $(GENHDR) \
-- lex.yy.c pcap-config
-+ lex.yy.c pcap-config $(OBJ_PIC)
+- lex.yy.c pcap-config libpcap.pc
++ lex.yy.c pcap-config libpcap.pc $(OBJ_PIC)
MAN1 = pcap-config.1
-@@ -365,7 +378,7 @@ libpcap.a: $(OBJ)
+@@ -386,7 +399,7 @@ libpcap.a: $(OBJ)
$(AR) rc $@ $(OBJ) $(ADDLARCHIVEOBJS)
$(RANLIB) $@
@@ -66,7 +66,7 @@ build a shared library.
libpcap.so: $(OBJ)
@rm -f $@
-@@ -443,6 +456,12 @@ libpcap.shareda: $(OBJ)
+@@ -462,6 +475,12 @@ libpcap.shareda: $(OBJ)
#
libpcap.none:
@@ -79,44 +79,37 @@ build a shared library.
scanner.c: $(srcdir)/scanner.l
$(LEX) -P pcap_ --header-file=scanner.h --nounput -o scanner.c $<
scanner.h: scanner.c
-@@ -455,6 +474,9 @@ scanner.h: scanner.c
+@@ -474,6 +493,9 @@ scanner.h: scanner.c
scanner.o: scanner.c grammar.h
$(CC) $(FULL_CFLAGS) -c scanner.c
+scanner_pic.o: scanner.c grammar.h
+ $(CC) -fPIC $(FULL_CFLAGS) -o $@ -c scanner.c
+
- pcap.o: pcap_version.h
-
grammar.c: $(srcdir)/grammar.y
-@@ -472,9 +494,16 @@ grammar.o: grammar.c
+ $(YACC) -p pcap_ -o grammar.c -d $<
+ grammar.h: grammar.c
+@@ -486,6 +508,9 @@ grammar.h: grammar.c
+ grammar.o: grammar.c scanner.h
+ $(CC) $(FULL_CFLAGS) -c grammar.c
+
++grammar_pic.o: grammar.c scanner.h
++ $(CC) -fPIC $(FULL_CFLAGS) -o $@ -c grammar.c
++
gencode.o: $(srcdir)/gencode.c grammar.h scanner.h
$(CC) $(FULL_CFLAGS) -c $(srcdir)/gencode.c
-+grammar_pic.o: grammar.c
-+ @rm -f $@
-+ $(CC) -fPIC $(FULL_CFLAGS) -Dyylval=pcap_lval -o $@ -c grammar.c
-+
- version.o: version.c
- $(CC) $(FULL_CFLAGS) -c version.c
-
-+version_pic.o: version.c
-+ $(CC) -fPIC $(FULL_CFLAGS) -c version.c -o $@
-+
- snprintf.o: $(srcdir)/missing/snprintf.c
- $(CC) $(FULL_CFLAGS) -o $@ -c $(srcdir)/missing/snprintf.c
-
-@@ -501,6 +530,9 @@ bpf_filter.c: $(srcdir)/bpf/net/bpf_filt
- bpf_filter.o: bpf_filter.c
- $(CC) $(FULL_CFLAGS) -c bpf_filter.c
+@@ -524,6 +549,9 @@ pcap-config: $(srcdir)/pcap-config.in ./
+ mv $@.tmp $@
+ chmod a+x $@
+bpf_filter_pic.o: bpf_filter.c
+ $(CC) -fPIC $(FULL_CFLAGS) -c bpf_filter.c -o $@
+
#
- # Generate the pcap-config script.
+ # Remote pcap daemon.
#
-@@ -623,14 +655,11 @@ install: install-shared install-archive
+@@ -614,14 +642,11 @@ install: install-shared install-archive
$(DESTDIR)$(mandir)/man@MAN_MISC_INFO@/`echo $$i | sed 's/.manmisc.in/.@MAN_MISC_INFO@/'`; done
install-shared: install-shared-$(DYEXT)
@@ -136,27 +129,27 @@ build a shared library.
(mkdir -p $(DESTDIR)$(libdir); chmod 755 $(DESTDIR)$(libdir))
--- a/aclocal.m4
+++ b/aclocal.m4
-@@ -470,7 +470,7 @@ AC_DEFUN(AC_LBL_SHLIBS_INIT,
+@@ -507,7 +507,7 @@ AC_DEFUN(AC_LBL_SHLIBS_INIT,
esac
;;
esac
-- V_CCOPT="$V_CCOPT $PIC_OPT"
-+ V_CCOPT="$V_CCOPT"
+- V_SHLIB_CCOPT="$V_SHLIB_CCOPT $PIC_OPT"
++ V_SHLIB_CCOPT="$V_SHLIB_CCOPT"
V_SONAME_OPT="-Wl,-soname,"
V_RPATH_OPT="-Wl,-rpath,"
;;
-@@ -533,7 +533,7 @@ AC_DEFUN(AC_LBL_SHLIBS_INIT,
+@@ -570,7 +570,7 @@ AC_DEFUN(AC_LBL_SHLIBS_INIT,
#
# "cc" is GCC.
#
-- V_CCOPT="$V_CCOPT -fpic"
-+ V_CCOPT="$V_CCOPT"
+- V_SHLIB_CCOPT="$V_SHLIB_CCOPT -fpic"
++ V_SHLIB_CCOPT="$V_SHLIB_CCOPT"
V_SHLIB_CMD="\$(CC)"
V_SHLIB_OPT="-shared"
V_SONAME_OPT="-Wl,-soname,"
--- a/pcap-config.in
+++ b/pcap-config.in
-@@ -36,16 +36,6 @@ do
+@@ -41,16 +41,6 @@ do
esac
shift
done