aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libcxx/patches/010-ssp.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-28 20:17:39 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-31 22:11:23 +0200
commit879e68eafd76dea0b5c2d47e3968d0535dc467af (patch)
tree7e8d8f1602d9425121f217c5e40f0f92323ae2e5 /package/libs/libcxx/patches/010-ssp.patch
parent3f9bd9e8ee609b82a709fc62d42187211dd9804f (diff)
downloadupstream-879e68eafd76dea0b5c2d47e3968d0535dc467af.tar.gz
upstream-879e68eafd76dea0b5c2d47e3968d0535dc467af.tar.bz2
upstream-879e68eafd76dea0b5c2d47e3968d0535dc467af.zip
libcxx: update to 10.0.0
Switched to upstream tarballs. Switched to libcxxabi as using libsupc++ is quite wonky. Fixed description. Removed patches. The fixes are cosmetic. Added ssp patch. This one is needed for i386 and powerpc under musl. Compile tested every C++ package in the tree with the exception of several boost packages. There's something broken with boost. Ran tested with gerbera. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/libcxx/patches/010-ssp.patch')
-rw-r--r--package/libs/libcxx/patches/010-ssp.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/libs/libcxx/patches/010-ssp.patch b/package/libs/libcxx/patches/010-ssp.patch
new file mode 100644
index 0000000000..f83c7b9b56
--- /dev/null
+++ b/package/libs/libcxx/patches/010-ssp.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -760,6 +760,10 @@ function(cxx_link_system_libraries targe
+ target_link_libraries(${target} PRIVATE atomic)
+ endif()
+
++ if (LIBCXX_HAS_MUSL_LIBC)
++ target_link_libraries(${target} PRIVATE ssp_nonshared)
++ endif()
++
+ if (MINGW)
+ target_link_libraries(${target} PRIVATE "${MINGW_LIBRARIES}")
+ endif()