aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libcxx/patches/010-cxx17.patch
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-08-28 20:17:39 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-08-31 22:11:23 +0200
commit879e68eafd76dea0b5c2d47e3968d0535dc467af (patch)
tree7e8d8f1602d9425121f217c5e40f0f92323ae2e5 /package/libs/libcxx/patches/010-cxx17.patch
parent3f9bd9e8ee609b82a709fc62d42187211dd9804f (diff)
downloadupstream-879e68eafd76dea0b5c2d47e3968d0535dc467af.tar.gz
upstream-879e68eafd76dea0b5c2d47e3968d0535dc467af.tar.bz2
upstream-879e68eafd76dea0b5c2d47e3968d0535dc467af.zip
libcxx: update to 10.0.0
Switched to upstream tarballs. Switched to libcxxabi as using libsupc++ is quite wonky. Fixed description. Removed patches. The fixes are cosmetic. Added ssp patch. This one is needed for i386 and powerpc under musl. Compile tested every C++ package in the tree with the exception of several boost packages. There's something broken with boost. Ran tested with gerbera. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/libcxx/patches/010-cxx17.patch')
-rw-r--r--package/libs/libcxx/patches/010-cxx17.patch14
1 files changed, 0 insertions, 14 deletions
diff --git a/package/libs/libcxx/patches/010-cxx17.patch b/package/libs/libcxx/patches/010-cxx17.patch
deleted file mode 100644
index dceec9d4f3..0000000000
--- a/package/libs/libcxx/patches/010-cxx17.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -524,9 +524,9 @@ remove_flags(-Wno-pedantic -pedantic-err
- if (LIBCXX_HAS_MUSL_LIBC OR LIBCXX_TARGETING_CLANG_CL)
- # musl's pthread implementations uses volatile types in their structs which is
- # not a constexpr in C++11 but is in C++14, so we use C++14 with musl.
-- set(LIBCXX_STANDARD_VER c++14 CACHE STRING "internal option to change build dialect")
-+ set(LIBCXX_STANDARD_VER c++2a CACHE STRING "internal option to change build dialect")
- else()
-- set(LIBCXX_STANDARD_VER c++11 CACHE STRING "internal option to change build dialect")
-+ set(LIBCXX_STANDARD_VER c++2a CACHE STRING "internal option to change build dialect")
- endif()
- add_compile_flags_if_supported(-std=${LIBCXX_STANDARD_VER})
- add_compile_flags_if_supported("/std:${LIBCXX_STANDARD_VER}")