aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/patches/101-no-fts.patch
diff options
context:
space:
mode:
authorLuiz Angelo Daros de Luca <luizluca@gmail.com>2017-05-05 20:05:56 -0300
committerJohn Crispin <john@phrozen.org>2017-05-18 07:59:56 +0200
commitccc54b29352a7d30762b84761414aa1798ce1183 (patch)
tree9a618d31503c170af5128acd92f78598071977bd /package/libs/elfutils/patches/101-no-fts.patch
parente00cc98045ac204d127d98dc882232b6982df359 (diff)
downloadupstream-ccc54b29352a7d30762b84761414aa1798ce1183.tar.gz
upstream-ccc54b29352a7d30762b84761414aa1798ce1183.tar.bz2
upstream-ccc54b29352a7d30762b84761414aa1798ce1183.zip
elfutils: bump to 0.169
Removed patches (now upstream): - 004-maybe-uninitialized.patch - 007-fix_TEMP_FAILURE_RETRY.patch Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Diffstat (limited to 'package/libs/elfutils/patches/101-no-fts.patch')
-rw-r--r--package/libs/elfutils/patches/101-no-fts.patch18
1 files changed, 11 insertions, 7 deletions
diff --git a/package/libs/elfutils/patches/101-no-fts.patch b/package/libs/elfutils/patches/101-no-fts.patch
index e6a672997d..63699fea26 100644
--- a/package/libs/elfutils/patches/101-no-fts.patch
+++ b/package/libs/elfutils/patches/101-no-fts.patch
@@ -1,6 +1,8 @@
---- a/libdwfl/argp-std.c
-+++ b/libdwfl/argp-std.c
-@@ -52,9 +52,6 @@ static const struct argp_option options[
+Index: elfutils-0.169/libdwfl/argp-std.c
+===================================================================
+--- elfutils-0.169.orig/libdwfl/argp-std.c
++++ elfutils-0.169/libdwfl/argp-std.c
+@@ -56,9 +56,6 @@ static const struct argp_option options[
{ "linux-process-map", 'M', "FILE", 0,
N_("Find addresses in files mapped as read from FILE"
" in Linux /proc/PID/maps format"), 0 },
@@ -10,7 +12,7 @@
{ "debuginfo-path", OPT_DEBUGINFO, "PATH", 0,
N_("Search path for separate debuginfo files"), 0 },
{ NULL, 0, NULL, 0, NULL, 0 }
-@@ -81,15 +78,6 @@ static const Dwfl_Callbacks proc_callbac
+@@ -85,15 +82,6 @@ static const Dwfl_Callbacks proc_callbac
.find_elf = INTUSE(dwfl_linux_proc_find_elf),
};
@@ -26,7 +28,7 @@
/* Structure held at state->HOOK. */
struct parse_opt
{
-@@ -219,43 +207,6 @@ parse_opt (int key, char *arg, struct ar
+@@ -223,43 +211,6 @@ parse_opt (int key, char *arg, struct ar
}
break;
@@ -70,8 +72,10 @@
case ARGP_KEY_SUCCESS:
{
struct parse_opt *opt = state->hook;
---- a/libdwfl/Makefile.in
-+++ b/libdwfl/Makefile.in
+Index: elfutils-0.169/libdwfl/Makefile.in
+===================================================================
+--- elfutils-0.169.orig/libdwfl/Makefile.in
++++ elfutils-0.169/libdwfl/Makefile.in
@@ -120,7 +120,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \