aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/Makefile
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-05 19:02:38 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-04-13 22:40:19 +0200
commitd27623b542548b765ddd46b046169006a3b5f66f (patch)
treed31289ad2ca24bfcb6a9c6a92780ea4f7a7c47fb /package/libs/elfutils/Makefile
parent76d22fc24b4d4a7e93b722af3005cc38bdef8111 (diff)
downloadupstream-d27623b542548b765ddd46b046169006a3b5f66f.tar.gz
upstream-d27623b542548b765ddd46b046169006a3b5f66f.tar.bz2
upstream-d27623b542548b765ddd46b046169006a3b5f66f.zip
elfutils: update to 0.179
Removed sys/cdefs usage. The header is deprecated. Removed canonicalize_file_name define. It's already fixed upstream. Added --disable-debuginfod. Seems to be needed. Modified patch 005 to build more stuff. It was failing before. It still only builds libraries. Modified patch 100 to use strerror under non-glibc. It is used under glibc as strerror is not thread safe. It is under musl and uClibc-ng. strerror_l is not available under uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'package/libs/elfutils/Makefile')
-rw-r--r--package/libs/elfutils/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 630c48820a..e6868c56f4 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
-PKG_VERSION:=0.177
-PKG_RELEASE:=2
+PKG_VERSION:=0.179
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
-PKG_HASH:=fa489deccbcae7d8c920f60d85906124c1989c591196d90e0fd668e3dc05042e
+PKG_HASH:=25a545566cbacaa37ae6222e58f1c48ea4570f53ba991886e2f5ce96e22a23a2
PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
PKG_LICENSE:=GPL-3.0-or-later
@@ -63,6 +63,7 @@ endif
CONFIGURE_ARGS += \
--program-prefix=eu- \
+ --disable-debuginfod \
--without-lzma
TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral