aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/elfutils/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-12-20 08:04:46 +0100
committerJo-Philipp Wich <jo@mein.io>2018-12-20 08:13:24 +0100
commitf2c6e2c3850e016dcae7afa48086b8feabd0af12 (patch)
tree35db3692129de05a839bda8ec8b613eb35c39e52 /package/libs/elfutils/Makefile
parent99ddff0c7f836e05156a0a084b2895ef2607811d (diff)
downloadupstream-f2c6e2c3850e016dcae7afa48086b8feabd0af12.tar.gz
upstream-f2c6e2c3850e016dcae7afa48086b8feabd0af12.tar.bz2
upstream-f2c6e2c3850e016dcae7afa48086b8feabd0af12.zip
elfutils: produce correct libelf.pc file when building with full nls
When building with full lagnuage support, libelf.so will depend on and link with libintl.so so we need to change the pkg-config template to reflect this library dependency. Also change the Makefile to only pass --disable-nls to configure when the full nls support is actually disabled in the buildroot config. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/libs/elfutils/Makefile')
-rw-r--r--package/libs/elfutils/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/libs/elfutils/Makefile b/package/libs/elfutils/Makefile
index 9fff14d283..8ac3a01176 100644
--- a/package/libs/elfutils/Makefile
+++ b/package/libs/elfutils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=elfutils
PKG_VERSION:=0.174
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -54,12 +54,13 @@ define Package/libelf1
endef
ifeq ($(CONFIG_BUILD_NLS),y)
-TARGET_LDFLAGS += "-lintl"
+TARGET_LDFLAGS += -lintl
+else
+CONFIGURE_ARGS += --disable-nls
endif
CONFIGURE_ARGS += \
--program-prefix=eu- \
- --disable-nls \
--without-lzma
TARGET_CFLAGS += -D_GNU_SOURCE -Wno-unused-result -Wno-format-nonliteral