aboutsummaryrefslogtreecommitdiffstats
path: root/package/librpc
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-12-08 16:49:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-12-08 16:49:45 +0000
commitffa53698c0c62d85c215ee3b74a85651a014941a (patch)
tree9620fa07c61f5bd6d1de245488602c306441aaea /package/librpc
parent589a8dfc24c70d2b417d1342af066a255c108ce8 (diff)
downloadupstream-ffa53698c0c62d85c215ee3b74a85651a014941a.tar.gz
upstream-ffa53698c0c62d85c215ee3b74a85651a014941a.tar.bz2
upstream-ffa53698c0c62d85c215ee3b74a85651a014941a.zip
[package] librpc: do not build if external or native toolchains are used
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29484 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/librpc')
-rw-r--r--package/librpc/Makefile29
1 files changed, 27 insertions, 2 deletions
diff --git a/package/librpc/Makefile b/package/librpc/Makefile
index 3cfb4c1227..5a46921164 100644
--- a/package/librpc/Makefile
+++ b/package/librpc/Makefile
@@ -9,7 +9,16 @@ PKG_SOURCE_URL:=git://nbd.name/uclibc-rpc.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=0a2179bbc0844928f2a0ec01dba93d9b5d6d41a7
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
-ifdef CONFIG_USE_UCLIBC
+
+ifndef CONFIG_NATIVE_TOOLCHAIN
+ ifndef CONFIG_EXTERNAL_TOOLCHAIN
+ ifdef CONFIG_USE_UCLIBC
+ BUILD_LIBRPC=1
+ endif
+ endif
+endif
+
+ifdef BUILD_LIBRPC
CMAKE_INSTALL:=1
endif
@@ -23,11 +32,27 @@ define Package/librpc
MDEPENDS:=@USE_UCLIBC
endef
-ifdef CONFIG_USE_UCLIBC
+ifdef BUILD_LIBRPC
define Package/librpc/install
$(INSTALL_DIR) $(1)/lib/
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/librpc.so $(1)/lib/
endef
+else
+ define Build/Prepare
+ endef
+
+ define Build/Configure
+ endef
+
+ define Build/Compile
+ endef
+
+ define Build/Install
+ endef
+
+ define Package/librpc/install
+ true
+ endef
endif
$(eval $(call BuildPackage,librpc))