aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-09-23 19:29:00 +0000
committerNicolas Thill <nico@openwrt.org>2006-09-23 19:29:00 +0000
commit9eb672070365b32f7611f93235d88aef196e930b (patch)
treed707d16d896ac1f5a9570ec7be82d7f0c52460f9 /package/libpcap
parentbfe072af7f640b37fdb0214ea75501ac6cc88870 (diff)
downloadupstream-9eb672070365b32f7611f93235d88aef196e930b.tar.gz
upstream-9eb672070365b32f7611f93235d88aef196e930b.tar.bz2
upstream-9eb672070365b32f7611f93235d88aef196e930b.zip
standardize Makefile, change section from base to libs
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4842 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/libpcap/Makefile b/package/libpcap/Makefile
index 1d9d4371fb..4fd1acae19 100644
--- a/package/libpcap/Makefile
+++ b/package/libpcap/Makefile
@@ -23,11 +23,13 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/libpcap
-SECTION:=base
-CATEGORY:=Libraries
-TITLE:=Low-level packet capture library
-DESCRIPTION:=A system-independent library for user-level network packet capture.
-URL:=http://www.tcpdump.org/
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Low-level packet capture library
+ DESCRIPTION:=\
+ This package contains a system-independent library for user-level \\\
+ network packet capture.
+ URL:=http://www.tcpdump.org/
endef
define Build/Configure
@@ -67,8 +69,6 @@ define Build/Configure
endef
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include" \
DESTDIR="$(PKG_INSTALL_DIR)" \