aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2010-03-05 20:24:13 +0000
committerTravis Kemen <thepeople@openwrt.org>2010-03-05 20:24:13 +0000
commit86c9f602a76b66d0dfd017c3f851783378ce2c87 (patch)
treee1185435c88c87ba3ff1d3cd830014b9e6d2816b /package/libpcap
parent91167603c878c35426d09c154a1d30142ac6a180 (diff)
downloadupstream-86c9f602a76b66d0dfd017c3f851783378ce2c87.tar.gz
upstream-86c9f602a76b66d0dfd017c3f851783378ce2c87.tar.bz2
upstream-86c9f602a76b66d0dfd017c3f851783378ce2c87.zip
this patch uses PKG_INSTALL:=1 and simplifies the Makefile,
separates the menuconfig options in a separates Config.in file, adds a new patch to disable man pages (there was an error with QUILT=1 without this patch, as ln was used without -f), renames patches to be more explicit (and 1xx for Makefile patches and 2xx for source patches) -Raphael git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19997 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/Makefile54
1 files changed, 21 insertions, 33 deletions
diff --git a/package/libpcap/Makefile b/package/libpcap/Makefile
index e54950002d..fcc9987c0f 100644
--- a/package/libpcap/Makefile
+++ b/package/libpcap/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpcap
PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.tcpdump.org/release/
PKG_MD5SUM:=9ad1358c5dec48456405eac197a46d3d
+PKG_INSTALL:=1
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/kernel.mk
@@ -26,28 +28,17 @@ define Package/libpcap
endef
define Package/libpcap/description
- This package contains a system-independent library for user-level network
- packet capture.
+This package contains a system-independent library for user-level network packet
+capture.
endef
define Package/libpcap/config
- config PCAP_HAS_USB
- bool "Include USB support"
- depends PACKAGE_libpcap
- depends PACKAGE_kmod-usb-core
- default n
-
- config PCAP_HAS_BT
- bool "Include bluetooth support"
- depends PACKAGE_libpcap
- depends PACKAGE_kmod-bluetooth
- depends BROKEN
- default n
-
+source "$(SOURCE)/Config.in"
endef
TARGET_CFLAGS += \
- -ffunction-sections -fdata-sections
+ -ffunction-sections \
+ -fdata-sections
CONFIGURE_VARS += \
ac_cv_linux_vers=$(LINUX_VERSION)
@@ -62,31 +53,28 @@ CONFIGURE_ARGS += \
--without-septel \
--without-dag
-define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
+MAKE_FLAGS += \
+ CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"
+
+define Build/Configure
+ $(call Build/Configure/Default)
$(if $(CONFIG_PCAP_HAS_USB),,$(SED) '/^#define PCAP_SUPPORT_USB/D' $(PKG_BUILD_DIR)/config.h)
$(if $(CONFIG_PCAP_HAS_USB),,$(SED) 's/pcap-usb-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
$(if $(CONFIG_PCAP_HAS_BT),,$(SED) '/^#define PCAP_SUPPORT_BT/D' $(PKG_BUILD_DIR)/config.h)
$(if $(CONFIG_PCAP_HAS_BT),,$(SED) 's/pcap-bt-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include" \
- DESTDIR="$(PKG_INSTALL_DIR)" \
- all install
endef
define Build/InstallDev
- mkdir -p $(1)/usr/include $(1)/usr/lib
- $(CP) \
- $(PKG_INSTALL_DIR)/usr/include/pcap* \
- $(1)/usr/include/
- $(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libpcap.{a,so*} \
- $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/pcap* $(1)/usr/include/
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.{a,so*} $(1)/usr/lib/
endef
define Package/libpcap/install
$(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libpcap))