aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-04-26 19:35:05 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-04-26 19:35:05 +0000
commit84d081aca9f865355a13849fbab49c9aaa97eaf9 (patch)
treef6d1eea7a182a23188370b766eb4ee9d1773cf61 /package/libpcap
parentf744c274df0452675bc1374d7fcaa96073f1e8ec (diff)
downloadupstream-84d081aca9f865355a13849fbab49c9aaa97eaf9.tar.gz
upstream-84d081aca9f865355a13849fbab49c9aaa97eaf9.tar.bz2
upstream-84d081aca9f865355a13849fbab49c9aaa97eaf9.zip
pcap: fix disabling bluetooth
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15428 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/libpcap/Makefile b/package/libpcap/Makefile
index bc6417d0e5..eef5ff0640 100644
--- a/package/libpcap/Makefile
+++ b/package/libpcap/Makefile
@@ -40,6 +40,7 @@ define Package/libpcap/config
bool "Include bluetooth support"
depends PACKAGE_libpcap
depends PACKAGE_kmod-bluetooth
+ depends BROKEN
default n
endef
@@ -62,6 +63,7 @@ define Build/Compile
$(if $(CONFIG_PCAP_HAS_USB),,$(SED) '/^#define PCAP_SUPPORT_USB/D' $(PKG_BUILD_DIR)/config.h)
$(if $(CONFIG_PCAP_HAS_USB),,$(SED) 's/pcap-usb-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
$(if $(CONFIG_PCAP_HAS_BT),,$(SED) '/^#define PCAP_SUPPORT_BT/D' $(PKG_BUILD_DIR)/config.h)
+ $(if $(CONFIG_PCAP_HAS_BT),,$(SED) 's/pcap-bt-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
$(MAKE) -C $(PKG_BUILD_DIR) \
CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include" \
DESTDIR="$(PKG_INSTALL_DIR)" \