aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
committerNicolas Thill <nico@openwrt.org>2005-05-19 21:14:18 +0000
commit1c478a693df182a4104311629c4a90159fc31c1f (patch)
treeda913501a3a383315403a2d10ab5f33bd357fdf1 /package/libpcap
parentc443f0ee7a69676ad3c0328ab2c0c376ddc1e380 (diff)
downloadupstream-1c478a693df182a4104311629c4a90159fc31c1f.tar.gz
upstream-1c478a693df182a4104311629c4a90159fc31c1f.tar.bz2
upstream-1c478a693df182a4104311629c4a90159fc31c1f.zip
Tweak package build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@968 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/libpcap/Makefile b/package/libpcap/Makefile
index bedebf2c7d..908c364a11 100644
--- a/package/libpcap/Makefile
+++ b/package/libpcap/Makefile
@@ -7,9 +7,7 @@ PKG_VERSION:=0.8.3
PKG_RELEASE:=1
PKG_MD5SUM:=56a9d4615d8354fcfe8cff8c8443c77b
-PKG_SOURCE_URL:= \
- http://www.tcpdump.org/release \
- http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
+PKG_SOURCE_URL:=http://www.tcpdump.org/release/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
@@ -53,16 +51,16 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
--with-build-cc=$(HOSTCC) \
--with-pcap=linux \
);
- touch $(PKG_BUILD_DIR)/.configured
+ touch $@
$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
- $(MAKE) -C $(PKG_BUILD_DIR) \
- CCOPT="$(TARGET_CFLAGS)"
+ rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
+ CCOPT="$(TARGET_CFLAGS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
- install
- touch $(PKG_BUILD_DIR)/.built
+ all install
+ touch $@
$(IPKG_LIBPCAP):
install -m0755 -d $(IDIR_LIBPCAP)/usr/lib