aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap/patches
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-24 10:36:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-24 10:36:25 +0000
commit1b802fb2bee6c937c3bdf42d996dded24180baad (patch)
tree66ccfa6307c7efe80c8b514568e2d4e154a25f17 /package/libpcap/patches
parent5171c481026c2dea7b96ee40d6f25f4b33eb0c32 (diff)
downloadupstream-1b802fb2bee6c937c3bdf42d996dded24180baad.tar.gz
upstream-1b802fb2bee6c937c3bdf42d996dded24180baad.tar.bz2
upstream-1b802fb2bee6c937c3bdf42d996dded24180baad.zip
[package] libpcap: add -fpic, refresh patches
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26999 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libpcap/patches')
-rw-r--r--package/libpcap/patches/102-makefile_disable_manpages.patch2
-rw-r--r--package/libpcap/patches/201-space_optimization.patch6
-rw-r--r--package/libpcap/patches/202-protocol_api.patch8
3 files changed, 8 insertions, 8 deletions
diff --git a/package/libpcap/patches/102-makefile_disable_manpages.patch b/package/libpcap/patches/102-makefile_disable_manpages.patch
index e9cde4f46a..7756c99ead 100644
--- a/package/libpcap/patches/102-makefile_disable_manpages.patch
+++ b/package/libpcap/patches/102-makefile_disable_manpages.patch
@@ -1,6 +1,6 @@
--- a/Makefile.in
+++ b/Makefile.in
-@@ -539,62 +539,12 @@ install: install-shared install-archive
+@@ -539,62 +539,12 @@ install: install-shared install-archive
(mkdir -p $(DESTDIR)$(includedir); chmod 755 $(DESTDIR)$(includedir))
[ -d $(DESTDIR)$(includedir)/pcap ] || \
(mkdir -p $(DESTDIR)$(includedir)/pcap; chmod 755 $(DESTDIR)$(includedir)/pcap)
diff --git a/package/libpcap/patches/201-space_optimization.patch b/package/libpcap/patches/201-space_optimization.patch
index 29c293b623..f3eec4c839 100644
--- a/package/libpcap/patches/201-space_optimization.patch
+++ b/package/libpcap/patches/201-space_optimization.patch
@@ -1,6 +1,6 @@
--- a/gencode.c
+++ b/gencode.c
-@@ -439,20 +439,6 @@ pcap_compile_nopcap(int snaplen_arg, int
+@@ -491,20 +491,6 @@ pcap_compile_nopcap(int snaplen_arg, int
}
/*
@@ -23,7 +23,7 @@
* back to another unresolved block (or nil). At least one of the fields
--- a/pcap.c
+++ b/pcap.c
-@@ -698,6 +698,59 @@ static const u_char charmap[] = {
+@@ -748,6 +748,59 @@ static const u_char charmap[] = {
(u_char)'\374', (u_char)'\375', (u_char)'\376', (u_char)'\377',
};
@@ -85,7 +85,7 @@
{
--- a/optimize.c
+++ b/optimize.c
-@@ -2278,45 +2278,6 @@ icode_to_fcode(root, lenp)
+@@ -2292,45 +2292,6 @@ icode_to_fcode(root, lenp)
return fp;
}
diff --git a/package/libpcap/patches/202-protocol_api.patch b/package/libpcap/patches/202-protocol_api.patch
index 892aeb7e0d..6d59b495d0 100644
--- a/package/libpcap/patches/202-protocol_api.patch
+++ b/package/libpcap/patches/202-protocol_api.patch
@@ -105,11 +105,10 @@
return (p);
}
-@@ -317,6 +319,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
- return 0;
+@@ -318,6 +320,15 @@ pcap_set_buffer_size(pcap_t *p, int buff
}
-+int
+ int
+pcap_set_protocol(pcap_t *p, unsigned short proto)
+{
+ if (pcap_check_activated(p))
@@ -118,9 +117,10 @@
+ return 0;
+}
+
- int
++int
pcap_activate(pcap_t *p)
{
+ int status;
--- a/pcap/pcap.h
+++ b/pcap/pcap.h
@@ -68,6 +68,7 @@ extern "C" {