aboutsummaryrefslogtreecommitdiffstats
path: root/package/libnl
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-28 09:22:10 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-28 09:22:10 +0000
commitcd3e48a9e2c5b31bef948d91d4a84516df76beaa (patch)
treef5c2f10e4ff97ff4ee7c3c4cbcb61fed45eb55bf /package/libnl
parentfb64f83ee057bb1b652ac9fc84d418b04b190efc (diff)
downloadupstream-cd3e48a9e2c5b31bef948d91d4a84516df76beaa.tar.gz
upstream-cd3e48a9e2c5b31bef948d91d4a84516df76beaa.tar.bz2
upstream-cd3e48a9e2c5b31bef948d91d4a84516df76beaa.zip
[package] libnl: update linux/genetlink.h for iw package (thanks to Hauke Mehrtens <hauke@hauke-m.de>)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14234 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libnl')
-rw-r--r--package/libnl/Makefile4
-rw-r--r--package/libnl/patches/160-update_includes_for_iw.patch34
2 files changed, 36 insertions, 2 deletions
diff --git a/package/libnl/Makefile b/package/libnl/Makefile
index b17bc09f28..682d8b8ecc 100644
--- a/package/libnl/Makefile
+++ b/package/libnl/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libnl
PKG_VERSION:=1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://people.suug.ch/~tgr/libnl/files/
diff --git a/package/libnl/patches/160-update_includes_for_iw.patch b/package/libnl/patches/160-update_includes_for_iw.patch
new file mode 100644
index 0000000000..ad36dab4ba
--- /dev/null
+++ b/package/libnl/patches/160-update_includes_for_iw.patch
@@ -0,0 +1,34 @@
+--- a/include/linux/genetlink.h
++++ b/include/linux/genetlink.h
+@@ -39,6 +39,9 @@ enum {
+ CTRL_CMD_NEWOPS,
+ CTRL_CMD_DELOPS,
+ CTRL_CMD_GETOPS,
++ CTRL_CMD_NEWMCAST_GRP,
++ CTRL_CMD_DELMCAST_GRP,
++ CTRL_CMD_GETMCAST_GRP, /* unused */
+ __CTRL_CMD_MAX,
+ };
+
+@@ -52,6 +55,7 @@ enum {
+ CTRL_ATTR_HDRSIZE,
+ CTRL_ATTR_MAXATTR,
+ CTRL_ATTR_OPS,
++ CTRL_ATTR_MCAST_GROUPS,
+ __CTRL_ATTR_MAX,
+ };
+
+@@ -66,4 +70,13 @@ enum {
+
+ #define CTRL_ATTR_OP_MAX (__CTRL_ATTR_OP_MAX - 1)
+
++enum {
++ CTRL_ATTR_MCAST_GRP_UNSPEC,
++ CTRL_ATTR_MCAST_GRP_NAME,
++ CTRL_ATTR_MCAST_GRP_ID,
++ __CTRL_ATTR_MCAST_GRP_MAX,
++};
++
++#define CTRL_ATTR_MCAST_GRP_MAX (__CTRL_ATTR_MCAST_GRP_MAX - 1)
++
+ #endif /* __LINUX_GENERIC_NETLINK_H */